Status

enhancement
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: chmanchester, Assigned: chmanchester)

Tracking

Trunk
mozilla65

Firefox Tracking Flags

(firefox64 fixed, firefox65 fixed)

Details

Attachments

(1 attachment)

We should land this on central before the merge.
FYI, this missed the merge :\
Flags: needinfo?(cmanchester)
Assignee

Comment 4

7 months ago
Dang. Thanks for the heads up. Will request uplift when it hits central.
Flags: needinfo?(cmanchester)

Comment 5

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/bb935ef08190
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Assignee

Comment 6

7 months ago
Comment on attachment 9018443 [details]
Bug 1500269 - Upgrade to rustc 1.29.2

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: Miscompilation bug in llvm that can trigger panics (and therefore crashes). See https://github.com/rust-lang/rust/pull/54639 for details.

Is this code covered by automated tests?: Unknown

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): The rustc 1.29.2 release contains only a small number of fixes on top of the rustc 1.29.0 release that has been used in automation since bug 1490145.

String changes made/needed:
Attachment #9018443 - Flags: approval-mozilla-beta?
Comment on attachment 9018443 [details]
Bug 1500269 - Upgrade to rustc 1.29.2

Updates the Rust compiler from version 1.29.0 to a less-buggy 1.29.2 instead. Approved for 64.0b4.
Attachment #9018443 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.