Closed Bug 1500329 Opened 2 years ago Closed 2 years ago

[remote-dbg-next] UX: Disconnect from a device

Categories

(DevTools :: about:debugging, enhancement, P2)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1512636

People

(Reporter: jdescottes, Unassigned)

References

Details

STRs:
- enable new about:debugging by setting devtools.aboutdebugging.new-enabled to true
- go to about:debugging
- select "Connect" page, enable USB Devices if not done already
- discover a Firefox for Android runtime (for instance)
- click on Connect (and accept prompt on the phone)
=> We are connected to the phone, but we have no way to disconnect!
  
Users can connect to USB or network location devices, but after that they cannot disconnect.
Note that the `DebuggerServer.destroy();` done in disconnectRuntime right now is actually only valid for THIS FIREFOX runtimes.
Priority: P3 → P2
Summary: [remote-dbg-next] Disconnect from a device → [remote-dbg-next] UX: Disconnect from a device
Blocks: 1505128
Blocks: 1501640
No longer blocks: 1505128

Disconnect button is getting UX specs in Bug 1512636

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1512636
No longer blocks: remote-debugging-ng-m2
You need to log in before you can comment on or make changes to this bug.