All users were logged out of Bugzilla on October 13th, 2018

microsoft.com - left edge of text is outside left edge of window content area

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: ericweb, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
Using Moz RC3 on WinXP Pro. 

To repro: view above page in Moz RC3, then in IE6. Looks fine in IE6 and Nav4;
but in Moz I can't read the leftmost character on every line because the left
margin is being positioned outside the left edge of the window's content area.

Interesting that MS appears to be using markup that looks fine in IE and Nav4
but just happens to be unreadable in Mozilla.

Suspect that something in this stylesheet might be at fault:
<link rel="stylesheet" type="text/css" href="/windows/windowsmedia/css/WinNN.css">

... which resolves to this URL:
http://www.microsoft.com/windows/windowsmedia/css/WinNN.css

Comment 1

17 years ago
->evang500
Keywords: evang500

Updated

17 years ago
Blocks: 114158
Summary: left edge of text is outside left edge of window content area → microsoft.com - left edge of text is outside left edge of window content area
*** Bug 155012 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
*** Bug 164571 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
The stylesheet mozilla gets given contains this right at the top:

Ahh.. yes.. top of the style sheet that mozilla gets given

BODY
{
    MARGIN: -10px 0px 0px -10px
}

Is it valid to do that ? How is the browser supposed to deal with that
situation.. surely it can't be correct to make part of the page invisible as a
result ?

Comment 5

16 years ago
w3.org (http://www.w3.org/TR/REC-CSS2/box.html#margin-properties) says this:

"Negative values for margin properties are allowed, but there may be
implementation-specific limits. "

unfortunately, it doesn't go into what those limits could be.

Can anyone think of a reason why we should honour negative margins that cause
part of the page to be hidden ? I can't think of any reason that a user would
want part of the page they're viewing to be unreadable, even if the browser is
honouring the negative values in the style sheet.

And what does "Tech Evangelism" mean exactly ?
*** Bug 167326 has been marked as a duplicate of this bug. ***
*** Bug 178689 has been marked as a duplicate of this bug. ***
*** Bug 151632 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 10

15 years ago
new URL:
http://www.microsoft.com/windows/windowsmedia/technologies.aspx
wfm using 2003082005 on Linux.
Stylesheet sent:
http://www.microsoft.com/windows/windowsmedia/css/newcss/WinNN7.css

[...]
BODY
{
    MARGIN: 0px 0px 0px 0px
}
[...]
Status: NEW → RESOLVED
Last Resolved: 15 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.