Port Bug 1492648 - Move from nsDocShellLoadInfo to nsDocShellLoadState

RESOLVED FIXED in Thunderbird 65.0

Status

defect
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: jorgk, Assigned: jorgk)

Tracking

Trunk
Thunderbird 65.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

8 months ago
Patch coming.
Assignee

Comment 1

8 months ago
Posted patch 1500347-loaduri.patch (obsolete) — Splinter Review
This should do it.
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #9018539 - Flags: review?(bzbarsky)
Assignee

Comment 2

8 months ago
BTW, what is the "first party load" about. We use it once.

Comment 3

8 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/3a91ffa3617c
Port Bug 1492648: nsIDocShell.loadURI() takes a nsDocShellLoadState parameter now. rs=bustage-fix
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Assignee

Updated

8 months ago
Target Milestone: --- → Thunderbird 64.0
Attachment #9018539 - Flags: review?(bzbarsky) → review?(kyle)

Comment 4

8 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/c7b5816c5071
Backed out changeset 3a91ffa3617c since ported bug 1492648 was backed out. a=backout
Assignee

Updated

8 months ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee

Updated

8 months ago
Blocks: 1492648

Comment 5

8 months ago
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/fb0fff3cd0f7
Port Bug 1492648: nsIDocShell.loadURI() takes a nsDocShellLoadState parameter now. rs=bustage-fix
Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → FIXED
I missed the boat for Daily, on account of having just 10 minutes to notice the m-c push, and then in a rush attempting to import the backout instead of the actual changes.
Target Milestone: Thunderbird 64.0 → Thunderbird 65.0
Assignee

Updated

8 months ago
Depends on: 1500420
Assignee

Updated

8 months ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

8 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/0f116c762e79
Backed out changeset fb0fff3cd0f7 since ported bug 1492648 was backed out. a=backout
Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → FIXED
Assignee

Updated

8 months ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ok, relanded bug 1492648 to m-i, now with comments pointing out the need for this change. Should I review this patch now?
Assignee

Updated

8 months ago
Duplicate of this bug: 1500420
Assignee

Comment 10

8 months ago
Comment on attachment 9018539 [details] [diff] [review]
1500347-loaduri.patch

I'll do a new patch.

So everywhere I use LOAD_FLAGS_IS_LINK I'll add a call to
loadState->SetLoadType(LOAD_LINK), right?
Attachment #9018539 - Flags: review?(kyle)
Assignee

Comment 12

8 months ago
OK, added the SetLoadType() calls where necessary.
Attachment #9018539 - Attachment is obsolete: true
Attachment #9021089 - Flags: review?(kyle)

Comment 13

8 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/251d4aa464d2
Port Bug 1492648: nsIDocShell.loadURI() takes a nsDocShellLoadState parameter now. rs=bustage-fix
Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → FIXED
Attachment #9021089 - Flags: review?(kyle) → review+
You need to log in before you can comment on or make changes to this bug.