Closed Bug 1500370 Opened Last year Closed Last year

Crash in TellMaybeSeek

Categories

(Core :: DOM: Core & HTML, defect, critical)

Unspecified
Linux
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 --- verified

People

(Reporter: calixte, Assigned: baku)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-4191f298-c4e2-4916-bfc7-fcb210181019.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so TellMaybeSeek xpcom/io/nsMultiplexInputStream.cpp:219
1 libxul.so nsMultiplexInputStream::Seek xpcom/io/nsMultiplexInputStream.cpp:614
2 libxul.so mozilla::FileMediaResource::ReadAt dom/media/FileMediaResource.cpp:225
3 libxul.so mozilla::MediaResourceIndex::ReadAt dom/media/MediaResource.cpp:428
4 libxul.so mozilla::ResourceStream::ReadAt dom/media/mp4/ResourceStream.cpp:34
5 libxul.so mozilla::SampleIterator::GetNext dom/media/mp4/Index.cpp:120
6 libxul.so mozilla::MP4TrackDemuxer::GetNextSample dom/media/mp4/MP4Demuxer.cpp:459
7 libxul.so mozilla::MP4TrackDemuxer::GetSamples dom/media/mp4/MP4Demuxer.cpp:534
8 libxul.so mozilla::detail::ProxyFunctionRunnable<mozilla::MediaFormatReader::DemuxerProxy::Wrapper::GetSamples dom/media/MediaFormatReader.cpp:881
9 libxul.so mozilla::TaskQueue::Runner::Run xpcom/threads/TaskQueue.cpp:235

=============================================================

There are 2 crashes (from 1 installation) in nightly 64 with buildid 20181019005426. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1496581.

[1] https://hg.mozilla.org/mozilla-central/rev?node=2da6504c901e
Flags: needinfo?(amarchesini)
Attached patch tell_2.patchSplinter Review
I suspect the bug is in MemoryBlobImpl
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
Attachment #9018599 - Flags: review?(honzab.moz)
Comment on attachment 9018599 [details] [diff] [review]
tell_2.patch

Review of attachment 9018599 [details] [diff] [review]:
-----------------------------------------------------------------

please check all classes listed in https://searchfox.org/mozilla-central/search?q=public+nsISeekableStream&case=true&regexp=false&path=

there are more missing this QI impl.
Attachment #9018599 - Flags: review?(honzab.moz) → review-
Comment on attachment 9018599 [details] [diff] [review]
tell_2.patch

Review of attachment 9018599 [details] [diff] [review]:
-----------------------------------------------------------------

searchfox not up to date!
Attachment #9018599 - Flags: review- → review+
Adding a Mac signature.
Crash Signature: [@ TellMaybeSeek] → [@ TellMaybeSeek] [@ nsMultiplexInputStream::Seek]
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fc083f953b3e
MemoryBlobImpl and TestNonBlockingAsyncInputStream must expose nsITellableInterface, r=mayhemer
https://hg.mozilla.org/mozilla-central/rev/fc083f953b3e
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
No more crashes since the patch landed.
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.