Closed Bug 1500383 Opened 11 months ago Closed 8 months ago

[remote-dbg-next] migrate aboutdebugging test: browser_addons_reload.js

Categories

(DevTools :: about:debugging, enhancement, P1)

enhancement

Tracking

(firefox66 fixed)

RESOLVED FIXED
Firefox 66
Tracking Status
firefox66 --- fixed

People

(Reporter: jdescottes, Assigned: jdescottes)

References

(Blocks 2 open bugs)

Details

(Whiteboard: old-remote-debugging-ng-m3)

Attachments

(3 files)

filter on remote-debugging-next-move-m3-to-m2
filter on remote-debugging-next-move-m3-to-m2
filter on remote-debugging-next-move-m3-to-m2
No longer blocks: remote-debugging-ng-m3
Priority: P3 → P2
Whiteboard: old-remote-debugging-ng-m3
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: P2 → P1
Using head-*.js as the name of a test helper makes it automagically visible from all
tests in the suite thanks to the import-headjs-globals.js plugin.

Renaming them to helper-*.js forces to explicitly import them and get linting errors
if we forgot to do so.

All helpers have been consistently renamed to helper-*.js. One method from the
collapsibilities helper has been moved to the main head.js, because it doesn't
have any relation with collapsing target panes.

All ADB tests also now check that ADB is not running before starting. I tried forcing
ADB to stop in this case, but we can't kill it from the tests apparently, so the only
option is for the user to manually kill the process. At least now we get a somewhat
helpful error message, and no timeout.
Depends on D15465

Some leftovers from previous bugs
Depends on D15466

Removed one of the test methods from the original test as I couldn't see the added value
Blocks: 1500384
Attachment #9033527 - Attachment description: Bug 1500383 - Migrate temporary addon reload test to new about:debugging;r=ladybenko,ola,daisuke → Bug 1500383 - Migrate tmp addon reload & remove tests to new about:debugging;r=ladybenko,ola,daisuke
Attachment #9033525 - Attachment description: Bug 1500383 - Rename test helpers to enable stronger linting;r=daisuke,ladybenko,ola → Bug 1500383 - Rename test helpers to enable stronger linting;r=daisuke,ola
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/edc7a186c29a
Rename test helpers to enable stronger linting;r=daisuke,Ola
https://hg.mozilla.org/integration/autoland/rev/fa39056b910d
Fix conflicts between bugs 857456 and 1510620;r=daisuke
https://hg.mozilla.org/integration/autoland/rev/013d4c77819e
Migrate tmp addon reload & remove tests to new about:debugging;r=daisuke
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Duplicate of this bug: 1500384
Duplicate of this bug: 1500382
You need to log in before you can comment on or make changes to this bug.