climbers-club.co.uk - Comment appears as displayed text

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: bluegrays, Unassigned)

Tracking

Details

(Whiteboard: [havefix][havecontac], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

The example code below is derived from Macromedia Fireworks. The comment code at
the start appears on the displayed page but the trailing comments do not (as
expected). This is the HTML code used in the example URL above.

    <td> <!-------------------------- BEGIN COPYING THE HTML HERE
----------------------------> 
      <img name="swales" src="maps/swales.jpg" width="654" height="495"
border="0" usemap="#m_swales"><map name="m_swales"> 
        <area shape="poly"
coords="378,113,382,329,477,385,470,454,636,449,643,3,433,3,303,53"
href="gbnoncc.htm" title="Gower & SE wales" alt="Gower & SE wales" > 
        <area shape="poly"
coords="293,54,377,121,378,333,324,354,321,403,286,398,238,403,216,432,152,419,38,334,43,320,119,298,116,252,60,246,46,246,36,216,149,119,196,128,246,106,293,54"
href="gbpembroke.htm" title="Pembroke" alt="Pembroke" > 
        <area shape="rect" coords="266,406,288,423" href="htmay.htm" title="May
Cottage" alt="May Cottage" > 
        <area shape="rect" coords="252,438,271,458" href="tides.htm"
title="Stackpole" alt="Stackpole" > 
        <area shape="rect" coords="15,234,36,252" href="tides.htm" title="Ramsey
Island" alt="Ramsey Island" > 
      </map> <!--------------------------- STOP COPYING THE HTML HERE
---------------------------> 


Reproducible: Always
Steps to Reproduce:
1.Open the page as per example
2.
3.

Actual Results:  Line immediatly above map should not be there.

Expected Results:  Comment data should be ignored.

Comment 1

17 years ago
parser
Assignee: Matti → harishd
Component: Browser-General → Parser
QA Contact: imajes-qa → moied

Comment 2

17 years ago
This occurs because the page is touting strict 2.0 compliance in the DOCTYPE. 
An SGML comment should not have a pair of hyphens in it, and that's basically
what this comment is doing.  The first <!-- opens the comment, and the
subsequent hyphens break the comment.

http://www.w3.org/TR/html4/intro/sgmltut.html#h-3.2.4

The "fix" would be to correct the comment or remove or replace the DOCTYPE
directive.

See bug 102127 for more information.

Comment 3

17 years ago
See

http://bugzilla.mozilla.org/show_bug.cgi?id=102127#c16
and
http://bugzilla.mozilla.org/show_bug.cgi?id=102127#c17

for a more detailed description of what's going on.

Confirming, ->tech evangelism

Contact details:ccwebmaster@bigfoot.com
Assignee: harishd → momoi
Status: UNCONFIRMED → NEW
Component: Parser → English: Non-US
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: moied → jeesun
Version: other → unspecified

Comment 4

17 years ago
UK Site -> Europe West
Assignee: momoi → nitot
Component: English: Non-US → Europe: West
QA Contact: jeesun → brantgurganus2001

Updated

17 years ago
Summary: Comment appears as displayed text → climbers-club.co.uk - Comment appears as displayed text
Whiteboard: [havefix][havecontac]

Comment 5

16 years ago
tech evang june 2003 reorg
Assignee: nitot → english-other
Component: Europe: West → English Other
QA Contact: brantgurganus2001 → english-other
page is 404, rest of the site is WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.