Slow rendering with <base href> and <body background> tags.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: sroddsson, Assigned: john)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

157 bytes, text/html
Details
(Reporter)

Description

16 years ago
When using phpmyadmin I noticed that Moz 1.0 renders the frame content painfully
slowly when switchin from another tab.

Steps to reproduce:
1. Load http://www.phpmyadmin.net/phpMyAdmin/ in a new window.
2. Create a new tab and load your favorite URL into it (e.g. http://www.mozilla.org)
3. Switch to the first tab (phpmyadmin tab). Rendering takes a lot of time (~1
second)

This is significantly improved in trunk build 20020607. I remember this being a
problem a long time ago (about 6 months) so this may be a regression.

My machine is a 450 MHz PIII which may be affecting the time it takes to render
the frameset/frame content.
(Assignee)

Comment 1

16 years ago
1. Is "significantly improved" the same as "good enough"?  I don't see a real
problem when I try it.  It's good speed on my 900MHz PIII/IV.

2. Is the 6th the first date where it seemed better to you?  Is the 5th the last
date it seemed bad?  We need the info on when it got better.  There's no chance
something like this will get into 1.0.1 unless (a) we can find the fix that
fixed it and (b) the fix is small and low-risk.

Comment 2

16 years ago
 Reporter which build are using. The performance is very good in today's branch 
and trunk builds: 20020607 on my WIN2K machine. It takes less than 1/2 second. I 
have a 600 MHz PIII. But that should not make any difference. Marking works for 
me (WFM). But if you still feel that there is a performance problem in recent 
builds please reopen it with build IDs and a testcase if possible.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

16 years ago
Created attachment 86869 [details]
test case

Slow rendering test case.
(Reporter)

Updated

16 years ago
Keywords: testcase
(Reporter)

Comment 4

16 years ago
This happens when there is a <base
href="http://www.papertowels.net/phpmyadmin/"> in the source paired with <body
background="images/bkg.gif">. This results in the background image being
http://www.papertowels.net/phpmyadmin/images/bkg.gif

Again, this seems to be fixed in trunk build 20020607 but is slow in 2002053012
(Moz 1.0 official).
Component: HTMLFrames → Layout
Summary: Frames rendering slow when switching between tabs → Slow rendering with <base href> and <body background> tags.
(Reporter)

Comment 5

16 years ago
Comment on attachment 86869 [details]
test case

><HTML><HEAD><TITLE>Test case</TITLE>
>
><BASE href="http://www.phpadmin.net/phpmyadmin/"/></HEAD><BODY background="images/bkg.gif">
></BODY></HTML>

Comment 6

16 years ago
um, fix this, no?

"Forbidden
You don't have permission to access /phpmyadmin/images/bkg.gif on this server."

You need to log in before you can comment on or make changes to this bug.