Tools button on about:addons loses its border upon clicking

VERIFIED FIXED in Firefox 64

Status

()

defect
P2
minor
VERIFIED FIXED
9 months ago
9 months ago

People

(Reporter: bruce.bugz, Assigned: dao)

Tracking

({regression})

unspecified
mozilla65
Unspecified
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 verified, firefox65 verified)

Details

Attachments

(4 attachments)

STR: Go to about:addons. Click the `Tools for all add-ons` button (the one that looks like [⚙˅]. Clicking it once is enough to reproduce the bug, but the button's :active:hover state has a blue background which makes it difficult to notice the bug. So better to click the button twice.

AR: Its border disappears; only the focus ring is left.
Posted image STR.gif
Easier to notice with something like #header-utils-btn {border-color: magenta !important;}
Blocks: 1492130
What OS are you on?
Flags: needinfo?(ampersand100000)
Keywords: regression
(In reply to Dão Gottwald [::dao] from comment #2)
> What OS are you on?

Sorry, it's Windows 10 1809.
Flags: needinfo?(ampersand100000)
OS: Unspecified → Windows
Assignee: nobody → dao+bmo
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2
This is happening because of a hack in toolbarbutton.css from
(In reply to Dão Gottwald [::dao] from comment #4)
> This is happening because of a hack in toolbarbutton.css from

... from bug 281932:

https://searchfox.org/mozilla-central/rev/72b1e834f384a2ffec6eb4ce405fbd4b5e881109/toolkit/themes/windows/global/toolbarbutton.css#31-33

It doesn't look like this is still needed.
Flags: qe-verify+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f62d1135e3d8
Clean up ancient toolbarbutton:-moz-focusring rule. r=paolo
https://hg.mozilla.org/mozilla-central/rev/f62d1135e3d8
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Comment on attachment 9020015 [details]
Bug 1500647 - Clean up ancient toolbarbutton:-moz-focusring rule. r?paolo

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1492130

User impact if declined: polish issue

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: see comment 0

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): trivial fix

String changes made/needed:
Attachment #9020015 - Flags: approval-mozilla-beta?
Comment on attachment 9020015 [details]
Bug 1500647 - Clean up ancient toolbarbutton:-moz-focusring rule. r?paolo

Minor polish fix. Approved for 64.0b5.
Attachment #9020015 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Hi Bruce, I tried reproducing this issue in older builds but without any luck, I tried a Nightly 64.0a1 (2018-10-19), as well as older versions of Beta, and even after setting the border color to Magenta I still couldn't cause it to occur. 
My Operating System is Windows 10 1511 with NVIDIA GeForce GT 730. I also tried different Windows 10 Machines and I wasn't able to reproduce the issue using your Steps.

Can you please try Using the latest Nightly version and re-check if the issue still occurs on your side? you will find it here: https://nightly.mozilla.org. 

Also tomorrow our latest beta version will be released, if you can check it there as well it would be a lot of help, you can find the build here: https://www.mozilla.org/en-US/firefox/channel/desktop/.
Flags: needinfo?(ampersand100000)
Hi Rares, I don't currently have access to a computer but I had received the Nightly update that fixed this a few days back and can confirm that the issue was indeed fixed for me. I can recheck in the latest Nightly and Beta when I get my laptop back from repairs (should be within this week)
I can confirm that the issue has been fixed in both Nightly 65.0a1 (2018-11-01) and Beta 64.0b5.

Attached is a gif with magenta borders on the button for improved visibility.
Flags: needinfo?(ampersand100000)
Thank you Bruce for re-checking this issue, Based on Comment 14 I will mark this issue as Verified.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.