Toolbarbuttons on dark LW-themes not correctly highlighted

RESOLVED FIXED in Thunderbird 64.0

Status

defect
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 64.0

Thunderbird Tracking Flags

(thunderbird_esr6063+ fixed, thunderbird64 fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

With dark LW-themes, not the built-in dark theme, the toolbarbuttons don't highlight with a white background but a darker, which isn't good visible. This applies on Linux and Windows, Mac isn't affected.
With a dark LW-theme, not the built-in dark theme, applied hover over the toolbarbuttons and check how they are highlighted. On Linux I also removed no more needed variables I missed to remove.

This all is a regression from the WX-theme work.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9018860 - Flags: review?(jorgk)
The same patch applying on beta, when you still want to build a 63 beta.
Attachment #9018861 - Flags: approval-comm-beta?
The ESR patch.
Attachment #9018862 - Flags: approval-comm-esr60?
Oops, sorry forgot the reviewer in the commit message. Please add it when landing.
Comment on attachment 9018860 [details] [diff] [review]
1500742-button-LW-themes.patch

Works OK, tested with "Dark Fox" and "Suave".
Attachment #9018860 - Flags: review?(jorgk) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/1c2a3007c1f5
Fix the toolbarbutton colors on dark LW-themes. r=jorgk DONTBUILD
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
Posted image suave-preview.png
The LW theme preview is distorted :-( - That's an M-C bug?
Comment on attachment 9018861 [details] [diff] [review]
1500742-button-LW-themes-beta.patch

Thanks, but not doing TB 63 beta 2.
Attachment #9018861 - Attachment is obsolete: true
Attachment #9018861 - Flags: approval-comm-beta?
Attachment #9018862 - Flags: approval-comm-esr60? → approval-comm-esr60+
You need to log in before you can comment on or make changes to this bug.