URLbar isn't focused after opening a new non-Private window when the privileged process is enabled

RESOLVED DUPLICATE of bug 1472212

Status

()

defect
RESOLVED DUPLICATE of bug 1472212
7 months ago
6 months ago

People

(Reporter: tgnff242, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

1. Create a new profile.
2. Set browser.tabs.remote.separatePrivilegedContentProcess to true and restart the browser.
3. Open a new _non-Private_ window and type something.


Actual results:

The URL bar isn't focused and you can't type immediately to it before you select it with a mouse or a keyboard shortcut.


Expected results:

I expected to be able to immediately write to the urlbar. This is the behavior for new tabs and Private windows, regardless of the status of the privileged process.
Reporter

Updated

7 months ago
Has STR: --- → yes
Component: Untriaged → Activity Streams: Newtab
Reporter

Updated

7 months ago
Blocks: 1472212
:mconley where should this be triaged to?
Flags: needinfo?(mconley)
Let's put it here for now.
Component: Activity Streams: Newtab → Address Bar
Flags: needinfo?(mconley)
The good news is that one of the patches in bug 1472212 actually fixes this:

https://hg.mozilla.org/mozreview/gecko/rev/0253c55229c44128e9c08a17d449cd24f9c7857b#index_header

So once that lands, this problem should be gone.
Reporter

Comment 4

6 months ago
Comment 3 is correct. I had seen the patch in Bug 1472212, but I had missed that it was backed out shortly after the first push. I would mark it as fixed, but, since I can't, I will mark it as duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1472212
You need to log in before you can comment on or make changes to this bug.