Closed Bug 1500876 Opened Last year Closed Last year

Remove PContent::GetSystemColors sync IPC

Categories

(Core :: Widget: Android, enhancement)

Unspecified
Android
enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: m_kato, Assigned: m_kato)

References

Details

Attachments

(1 file)

GetSystemColors is sync IPC of content.  But it is unnecessary to use sync IPC since we can use SetIntCacheImpl / GetIntCacheImpl instead.
Content process of Android uses sync IPC when initializing LookAndFeel. But
current e10s has LookAndFeel cache for start up of content process.
So we should use it, then remove sync IPC for start up performance
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/d2e24bdf0648
Remove PContent::GetSystemColors sync IPC. r=snorp,mccr8
https://hg.mozilla.org/mozilla-central/rev/d2e24bdf0648
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Please request Beta approval on this when you get a chance.
Flags: needinfo?(m_kato)
Comment on attachment 9019926 [details]
Bug 1500876 - Remove PContent::GetSystemColors sync IPC. r?snorp

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: This is GeckoView only since GV uses e10s.  When creating content process, its process want to get system colors for text, window and etc.  But Gecko uses synchronous IPC to get it, so we stop using synchronous IPC to improve start up performance.
Also ,this fixes bug 1456947

Is this code covered by automated tests?: Unknown

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Send color information (text, window, background and etc) of parent process to content process when creating content process.
Before fixing this, Gecko uses sync IPC if content process needs color information.

String changes made/needed: no
Flags: needinfo?(m_kato)
Attachment #9019926 - Flags: approval-mozilla-beta?
Comment on attachment 9019926 [details]
Bug 1500876 - Remove PContent::GetSystemColors sync IPC. r?snorp

[Triage Comment]
GeckoView perf and security improvement. Approved for 64.0b6.
Attachment #9019926 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.