'Accept third-party cookies and site data' set to 'Never' not reflected in navigator.cookieEnabled property of an iframed document.

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 months ago
4 months ago

People

(Reporter: evan.t.nichols, Unassigned)

Tracking

60 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.67 Safari/537.36

Steps to reproduce:

1) Open up Firefox preferences and set 'Accept third party cookies and site data' to 'Never'.
2) Open https://codepen.io/etnichols/pen/JmBewR or any site that has an iframed site within it.
3) Use the Firefox Developer tools (https://developer.mozilla.org/en-US/docs/Tools/Working_with_iframes) to inspect the iframe element.
4) In the developer console run 'navigator.cookieEnabled.'


Actual results:

navigator.cookieEnabled returns true.

Screencast of this behavior: https://drive.google.com/file/d/1_uExs39uHbU7F0AN4ekBkTuKhrCKVLuU/view?usp=sharing


Expected results:

navigator.cookieEnabled returns false.

Screencast of expected behavior, using Google Chrome: https://drive.google.com/file/d/14IYhcA3rqw8q7DpqKnFePEPAwOThppVd/view?usp=sharing
(Reporter)

Updated

4 months ago
Summary: 'Accept third-party cookies and site data' set to 'Never' not reflected in navigator.cookieEnabled property. → 'Accept third-party cookies and site data' set to 'Never' not reflected in navigator.cookieEnabled property of an iframed document.

Comment 1

4 months ago
Hi,

I've reproduced the issue described above on Firefox Release v.62.0 Build ID: 20180830143136.
    
I've also tried on the latest Firefox Release version 63.0 Build ID:20181018182531, on Ubuntu 16.04 and Win10 x64, but couldn't reproduce the issue. In the newest Release the Content Blocking section has changed, as such following your steps don't reproduce the issue. 

Could you also update to the latest version of Firefox and confirm that the issue is not present anymore?
Flags: needinfo?(evan.t.nichols)
(Reporter)

Comment 2

4 months ago
Thanks for the info Laszlo. I updated to the latest version of Firefox v63.0 Build ID 20181018182531 and confirmed the issue is no longer present. This bug can be closed/marked as obsolete.
Flags: needinfo?(evan.t.nichols)
(Reporter)

Updated

4 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.