Closed Bug 1500965 Opened 1 year ago Closed 1 year ago

Fix todo_is in toolkit/components/normandy/test/browser/browser_PreferenceExperiments.js

Categories

(Firefox :: Normandy Client, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 65
Tracking Status
firefox65 --- fixed

People

(Reporter: jdescottes, Assigned: mythmon)

References

Details

Attachments

(1 file)

Bug 1499096 will switch a call to ok() to is(). Most likely intended by the author of the test, but the assert fails at the moment:

    todo_is(
      Services.prefs.getPrefType(`${startupPrefs}.fake.user`),
      Services.prefs.PREF_INVALID,
      "The startup value for fake.user was not set",
    );
Blocks: 1500966
Duplicate of this bug: 1500966
Component: General → Marionette
Product: Firefox → Testing
Component: Marionette → General
Product: Testing → Firefox
Component: General → Normandy Client
Priority: P3 → --
Assignee: nobody → mcooper
Status: NEW → ASSIGNED
Pushed by mcooper@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/810db9f8006b
Fix todo_is in toolkit/components/normandy/test/browser/browser_PreferenceExperiments.js r=Gijs
https://hg.mozilla.org/mozilla-central/rev/810db9f8006b
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
You need to log in before you can comment on or make changes to this bug.