[mach] Mach-O build fails with gcc3 from April Developer's tools

RESOLVED WONTFIX

Status

()

Core
XPCOM
RESOLVED WONTFIX
16 years ago
16 years ago

People

(Reporter: Marcus Pallinger, Assigned: dougt)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
make[4]: Entering directory `/Users/marcus/mozilla/xpcom/ds'
nsArena.cpp
c++ -o nsArena.o -c -DOSTYPE=\"Darwin5.5\" -DOSARCH=\"Darwin\" -DOJI
-D_IMPL_NS_COM -D_IMPL_NS_BASE  -I../../dist/include/string
-I../../dist/include/xpcom -I../../dist/include
-I/Users/marcus/mozilla/dist/include/nspr      -I/usr/X11R6/include   -fPIC 
-I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Wbad-function-cast -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-long-long -fpascal-strings -traditional-cpp
-fno-common -I/Developer/Headers/FlatCarbon -F/System/Library/Frameworks -pipe 
-DNDEBUG -DTRIMMED -O2  -I/usr/X11R6/include -DMOZILLA_CLIENT -include
../../config-defs.h -Wp,-MD,.deps/nsArena.pp nsArena.cpp
In file included from /usr/include/gcc/darwin/3.1/g++-v3/backward/new.h:33,
                 from nsCppSharedAllocator.h:6,
                 from nsCRT.h:45,
                 from nsArena.cpp:40:
/usr/include/gcc/darwin/3.1/g++-v3/backward/backward_warning.h:32:2: warning:
#warning This file includes at least one deprecated or antiquated header. Please
consider using one of the 32 headers found in section 17.4.1.2 of the C++
standard. Examples include substituting the <X> header for the <X.h> header for
C++ includes, or <sstream> instead of the deprecated header <strstream.h>. To
disable this warning use -Wno-deprecated.
../../dist/include/xpcom/nsISupportsUtils.h: In member function `virtual 
   nsresult ArenaImpl::QueryInterface(const nsIID&, void**)':
../../dist/include/xpcom/nsISupportsUtils.h:254: const nsIID 
   iid_NS_ISUPPORTS_IID causes a section type conflict
make[4]: *** [nsArena.o] Error 1
make[4]: Leaving directory `/Users/marcus/mozilla/xpcom/ds'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/Users/marcus/mozilla/xpcom'
make[2]: *** [tier_2] Error 2
make[2]: Leaving directory `/Users/marcus/mozilla'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/Users/marcus/mozilla'
make: *** [build] Error 2
make: Leaving directory `/Users/marcus/mozilla'

My .mozconfig file contains:
ac_add_options --disable-tests
ac_add_options --enable-crypto
ac_add_options --disable-debug
ac_add_options --disable-mailnews
ac_add_options --enable-plaintext-editor-only
ac_add_options --with-extensions=default

ac_add_options --disable-ldap

ac_add_options --disable-debug
ac_add_options --enable-optimize=-O2

ac_add_options --with-glib-prefix=/sw
ac_add_options --with-libIDL-prefix=/sw

MOZILLA_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1
BUILD_OFFICIAL=1
mk_add_options BUILD_OFFICIAL=1

mk_add_options MOZ_CVS_FLAGS="-q -z9 -d :pserver:anonymous@cvs-mirror.mozilla.or
g:/cvsroot"

Ot works fine with the version of gcc2 supplied with the developer's tools

Comment 1

16 years ago
see bug 71627
(Reporter)

Comment 2

16 years ago
I could be wrong, but it looks like bug 71627 is for a crasher rather than
compile error.

Comment 3

16 years ago
actually bug 71627 is a compile problem

Comment 4

16 years ago
I can confirm that this error occurs in Fink's compilation of Mozilla. Note that at Fink, we currently 
expect Mac OS X 10.2 to have gcc3 as the default compiler. 
This is fixed in the gcc3 in the Jaguar beta release (6C75).  See bug 153525. 
It's also not a bug we intend to fix, since the compiler is seriously broken and
working around all the problems would be impossible to really do correctly
(although you can use the patch on bug 153525 if you want).

->wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.