disable-calendar does not work in SeaMonkey via mozconfig

RESOLVED FIXED in Thunderbird 65.0

Status

defect
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: frg, Assigned: frg)

Tracking

Trunk
Thunderbird 65.0

SeaMonkey Tracking Flags

(seamonkey2.53 unaffected, seamonkey2.57esr fixed)

Details

Attachments

(1 attachment)

Assignee

Description

8 months ago
When working on bug 1500747 Bill found that using disable-calendar in the seamonkey mozconfig results in a configure error. We have it globally enabled for building instead of specifying it in the in-tree mozconfigs.


0:05.48   File "d:/seamonkey/comm-esr60/configure.py", line 127, in <module>
 0:05.48     sys.exit(main(sys.argv))
 0:05.48   File "d:/seamonkey/comm-esr60/configure.py", line 29, in main
 0:05.48     sandbox.run(os.path.join(os.path.dirname(__file__), 'moz.configure'))
 0:05.49   File "d:\seamonkey\comm-esr60\python\mozbuild\mozbuild\configure\__init__.py", line 409, in run
 0:05.49     self._value_for(option)
 0:05.49   File "d:\seamonkey\comm-esr60\python\mozbuild\mozbuild\configure\__init__.py", line 477, in _value_for
 0:05.49     return self._value_for_option(obj)
 0:05.49   File "d:\seamonkey\comm-esr60\python\mozbuild\mozbuild\util.py", line 944, in method_call
 0:05.49     cache[args] = self.func(instance, *args)
 0:05.51   File "d:\seamonkey\comm-esr60\python\mozbuild\mozbuild\configure\__init__.py", line 528, in _value_for_option
 0:05.51     % (e.arg, reason, e.old_arg, e.old_origin))
 0:05.51 mozbuild.configure.options.InvalidOptionError: '--enable-calendar' implied by 'imply_option at d:/seamonkey/comm-esr60/comm
/suite/moz.configure:16' conflicts with '--disable-calendar' from the mozconfig
 0:05.57 *** Fix above errors and then restart with\
 0:05.57                "c:/mozilla-build/bin/mozmake.EXE -f client.mk build"
 0:05.58 mozmake.EXE: *** [client.mk:149: configure] Error 1

+++ This bug was initially created as a clone of Bug #1500747 +++

Currently building DOMi, cZ and debugQA is disabled hard in confvars.sh because of bug 1231349. All three are being fixed for 2.57 so it should be at least possible to enable building them in local en-US builds without changing confvars.sh.
Assignee

Comment 1

8 months ago
Jorg, patch from Bill. Not sure if you you are the right reviewer for releng stuff. If it gets r+ I would like to move it to esr60 too. Not urgent.
Attachment #9019164 - Flags: review?(jorgk)

Comment 2

8 months ago
Comment on attachment 9019164 [details] [diff] [review]
1501093-mozconfig-calendar.patch

I'm keeping out of build stuff.
Attachment #9019164 - Flags: review?(jorgk) → review?(rob)

Comment 3

8 months ago
Comment on attachment 9019164 [details] [diff] [review]
1501093-mozconfig-calendar.patch

Review of attachment 9019164 [details] [diff] [review]:
-----------------------------------------------------------------

This looks fine.
Attachment #9019164 - Flags: review?(rob) → review+
Assignee

Updated

8 months ago
Keywords: checkin-needed
Summary: disable-calendar does not wirh in SeaMonkey via mozconfig → disable-calendar does not work in SeaMonkey via mozconfig
Assignee

Comment 4

8 months ago
Comment on attachment 9019164 [details] [diff] [review]
1501093-mozconfig-calendar.patch

Thanks. Could you take it to esr60 if it does not cause problems in c-c

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: minor. Building Lightning can not be disabled in local builds (will always be enabled in official builds)
Testing completed (on c-c, etc.): c-esr60
Risk to taking this patch (and alternatives if risky): trivial fix.
Attachment #9019164 - Flags: approval-comm-esr60?

Comment 5

8 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/3f7e3c78bdd8
Permit overriding enable-calendar in SeaMonkey via mozconfig. r=rjl
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

8 months ago
Target Milestone: --- → Thunderbird 65.0

Updated

8 months ago
Attachment #9019164 - Flags: approval-comm-esr60? → approval-comm-esr60+
You need to log in before you can comment on or make changes to this bug.