Closed Bug 15011 Opened 20 years ago Closed 20 years ago

Clicked Back button; crashed in FrameManager

Categories

(Core :: Layout, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 14967

People

(Reporter: phil, Assigned: nisheeth_mozilla)

Details

I've seen this a couple of times now. Was just mousing around in the browser,
and when I hit the Back button, I died with this stack trace. Looks like aState
has already been deleted.

FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026ca100, nsILayoutHistoryState * 0x01a95700) line 1102 + 21 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026ca6b0, nsILayoutHistoryState * 0x01a95700) line 1127 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026cab60, nsILayoutHistoryState * 0x01a95700) line 1120 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026cbb70, nsILayoutHistoryState * 0x01a95700) line 1127 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026cc080, nsILayoutHistoryState * 0x01a95700) line 1120 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026cc570, nsILayoutHistoryState * 0x01a95700) line 1127 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026c3b80, nsILayoutHistoryState * 0x01a95700) line 1127 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026c2270, nsILayoutHistoryState * 0x01a95700) line 1127 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026bf9c0, nsILayoutHistoryState * 0x01a95700) line 1127 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026bb110, nsILayoutHistoryState * 0x01a95700) line 1127 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026bb300, nsILayoutHistoryState * 0x01a95700) line 1127 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026b3990, nsILayoutHistoryState * 0x01a95700) line 1127 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026b2210, nsILayoutHistoryState * 0x01a95700) line 1127 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026b26e0, nsILayoutHistoryState * 0x01a95700) line 1127 + 20 bytes
FrameManager::RestoreFrameState(FrameManager * const 0x026aa620, nsIFrame *
0x026b5460, nsILayoutHistoryState * 0x01a95700) line 1120 + 20 bytes
PresShell::ContentAppended(PresShell * const 0x026aa9f8, nsIDocument *
0x0273aaa0, nsIContent * 0x026ab67c, int 0x00000008) line 1735
nsDocument::ContentAppended(nsDocument * const 0x0273aaa0, nsIContent *
0x026ab67c, int 0x00000008) line 1574
nsHTMLDocument::ContentAppended(nsHTMLDocument * const 0x0273aaa0, nsIContent *
0x026ab67c, int 0x00000008) line 1044
HTMLContentSink::NotifyBody() line 276
HTMLContentSink::WillInterrupt(HTMLContentSink * const 0x0273ff10) line 1770
CNavDTD::WillInterruptParse(CNavDTD * const 0x026aa2c0) line 3111 + 27 bytes
nsParser::ResumeParse(nsIDTD * 0x00000000, int 0x00000000) line 958
nsParser::OnDataAvailable(nsParser * const 0x0273a1c4, nsIChannel * 0x027357e0,
nsISupports * 0x00000000, nsIInputStream * 0x0273e1c8, unsigned int 0x00000000,
unsigned int 0x00000142) line 1337 + 19 bytes
nsDocumentBindInfo::OnDataAvailable(nsDocumentBindInfo * const 0x02735710,
nsIChannel * 0x027357e0, nsISupports * 0x00000000, nsIInputStream * 0x0273e1c8,
unsigned int 0x00000000, unsigned int 0x00000142) line 1371 + 32 bytes
nsChannelListener::OnDataAvailable(nsChannelListener * const 0x027355d0,
nsIChannel * 0x027357e0, nsISupports * 0x00000000, nsIInputStream * 0x0273e1c8,
unsigned int 0x00000000, unsigned int 0x00000142) line 1613
nsHTTPResponseListener::OnDataAvailable(nsHTTPResponseListener * const
0x0273e8b0, nsIChannel * 0x0273a6a0, nsISupports * 0x027357e0, nsIInputStream *
0x0273e1c8, unsigned int 0x00000482, unsigned int 0x00000142) line 186 + 47
bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x027381d0)
line 359
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x0273a790) line 152 + 12 bytes
PL_HandleEvent(PLEvent * 0x0273a790) line 541 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0098d500) line 500 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x17b902ec, unsigned int 0x0000c0e5, unsigned int
0x00000000, long 0x0098d500) line 970 + 9 bytes
USER32! 77e71820()
0098d500()
Assignee: troy → nisheeth
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 14967 ***
Status: RESOLVED → VERIFIED
Marking as verified duplicate of 14967.
You need to log in before you can comment on or make changes to this bug.