Closed Bug 1501178 Opened 10 months ago Closed 10 months ago

4.75% build times (linux64) regression on push c43c91d2b97b (Mon Oct 22 2018)

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 unaffected, firefox65 fixed)

VERIFIED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- fixed

People

(Reporter: igoldan, Assigned: cmanchester)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=80361808cf668648a20a3da2bdafb62ffbe04dd4&tochange=c43c91d2b97b1d1b230efdabce8b67d52e5cda27

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  5%  build times linux64 opt plain taskcluster-c4.4xlarge     1,580.87 -> 1,656.01


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=17018

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics
Product: Testing → Firefox Build System
Flags: needinfo?(cmanchester)
Assignee: nobody → cmanchester
I was actively investigating this and unaware there was a deadline to respond in order to avoid backout. This deadline would be good to include in the bug report/needinfo so people are aware of the situation. Had I been, I certainly would have reported on my progress investigating.
Flags: needinfo?(cmanchester)
Depends on: 1503195
(In reply to Chris Manchester (:chmanchester) from comment #1)
> I was actively investigating this and unaware there was a deadline to
> respond in order to avoid backout. This deadline would be good to include in
> the bug report/needinfo so people are aware of the situation. Had I been, I
> certainly would have reported on my progress investigating.


I'm addressing this. I filed bug 1503195 for that.
(In reply to Ionuț Goldan [:igoldan], Performance Sheriffing from comment #2)
> (In reply to Chris Manchester (:chmanchester) from comment #1)
> > I was actively investigating this and unaware there was a deadline to
> > respond in order to avoid backout. This deadline would be good to include in
> > the bug report/needinfo so people are aware of the situation. Had I been, I
> > certainly would have reported on my progress investigating.
> 
> 
> I'm addressing this. I filed bug 1503195 for that.

Thanks!
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/51f379d29373
Prioritize directories containing rust compilation in the make backend. r=nalexander
https://hg.mozilla.org/mozilla-central/rev/51f379d29373
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Duplicate of this bug: 1372813

I confirm this got fixed:

== Change summary for alert #17249 (as of Mon, 29 Oct 2018 07:30:25 GMT) ==

Improvements:

8% build times linux64 opt plain taskcluster-m5d.4xlarge 1,438.39 -> 1,329.29

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=17249

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.