Closed Bug 1501218 Opened Last year Closed Last year

Please build with cairo-gtk3-wayland target on Linux

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: stransky, Assigned: glandium)

References

Details

Attachments

(1 file)

Would be great to have cairo-gtk3-wayland try build target to make sure incoming patches does not break it. No need to run automated test on it now.
Depends on: 1501944
As the Bug 1501944 and Bug 1503592 landed Firefox can be build with cairo-gtk3-wayland on Gtk 3.10 now. It just needs to rebuild gtk3 packages in mozilla build roots with --enable-wayland-backend.
Summary: Please add cairo-gtk3-wayland try build target → Please build with cairo-gtk3-wayland try build target
Summary: Please build with cairo-gtk3-wayland try build target → Please build with cairo-gtk3-wayland target on Linux
This should be a matter of adding a new platform in taskcluster/ci/build -- something you can even "try out" in try before landing.  There's a good bit of documentation in https://firefox-source-docs.mozilla.org/taskcluster/taskcluster/ if that helps, but cargo-culting will get you most of the way there :)
Flags: needinfo?(stransky)
(In reply to Dustin J. Mitchell [:dustin] pronoun: he from comment #2)
> This should be a matter of adding a new platform in taskcluster/ci/build --
> something you can even "try out" in try before landing.  There's a good bit
> of documentation in
> https://firefox-source-docs.mozilla.org/taskcluster/taskcluster/ if that
> helps, but cargo-culting will get you most of the way there :)

I think it would be better to just switch all linux builds to wayland target but that needs gtk 3.10 in build roots (AFAIK recently is used 3.4). Does that covers the doc you posted?
Flags: needinfo?(stransky)
I have WIP to get Firefox built against Gtk+3 3.10. Interestingly, it seems the result is still binary compatible with Gtk+3 3.4. I'll finish that next week.
Depends on: 1504906, 1504904
Depends on: 1504937
Depends on: 1504936
Depends on: 1504938
No longer depends on: 1504936
Depends on: 1504951
Depends on: 1505023
Depends on: 1505307
--enable-default-toolkit=cairo-gtk3-wayland is left to _force_ wayland
support being built in, while --enable-default-toolkit=cairo-gtk3 still
allows to build against a Gtk+ version that doesn't support wayland.
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/3d38289ea246
Enable wayland support with --enable-default-toolkit=cairo-gtk3. r=firefox-build-system-reviewers,mshal
Backed out changeset 3d38289ea246 (Bug 1501218) for linux build bustages 

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=3d38289ea246a45c3aa71a409448c3040d640055

Backout link: https://hg.mozilla.org/integration/autoland/rev/91ef9daa39b6b99754389139914d3c2566bad123

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=211558209&repo=autoland&lineNumber=27726

[task 2018-11-13T23:32:26.329Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers/gdk/gdkwayland.h:3,
[task 2018-11-13T23:32:26.329Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/widget/gtk/nsWindow.h:18,
[task 2018-11-13T23:32:26.329Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/widget/gtk/nsWindow.cpp:8:
[task 2018-11-13T23:32:26.330Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/bits/move.h:45:3: error: template with C linkage
[task 2018-11-13T23:32:26.330Z] 23:32:26     INFO -     template<typename _Tp>
[task 2018-11-13T23:32:26.330Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.330Z] 23:32:26     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers/type_traits:3:0,
[task 2018-11-13T23:32:26.331Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers/type_traits:44,
[task 2018-11-13T23:32:26.331Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/bits/move.h:57,
[task 2018-11-13T23:32:26.331Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/bits/nested_exception.h:40,
[task 2018-11-13T23:32:26.331Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/exception:171,
[task 2018-11-13T23:32:26.331Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers/exception:3,
[task 2018-11-13T23:32:26.332Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/new:40,
[task 2018-11-13T23:32:26.332Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers/new:3,
[task 2018-11-13T23:32:26.336Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers/new:44,
[task 2018-11-13T23:32:26.336Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dist/include/mozilla/mozalloc.h:16,
[task 2018-11-13T23:32:26.336Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers/cmath:50,
[task 2018-11-13T23:32:26.337Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/math.h:36,
[task 2018-11-13T23:32:26.337Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers/math.h:3,
[task 2018-11-13T23:32:26.337Z] 23:32:26     INFO -                   from /usr/include/wayland-util.h:30,
[task 2018-11-13T23:32:26.337Z] 23:32:26     INFO -                   from /usr/include/wayland-client.h:26,
[task 2018-11-13T23:32:26.338Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers/wayland-client.h:3,
[task 2018-11-13T23:32:26.338Z] 23:32:26     INFO -                   from /usr/include/gtk-3.0/gdk/wayland/gdkwaylanddevice.h:27,
[task 2018-11-13T23:32:26.338Z] 23:32:26     INFO -                   from /usr/include/gtk-3.0/gdk/gdkwayland.h:32,
[task 2018-11-13T23:32:26.338Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers/gdk/gdkwayland.h:3,
[task 2018-11-13T23:32:26.339Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/widget/gtk/nsWindow.h:18,
[task 2018-11-13T23:32:26.339Z] 23:32:26     INFO -                   from /builds/worker/workspace/build/src/widget/gtk/nsWindow.cpp:8:
[task 2018-11-13T23:32:26.339Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:68:3: error: template with C linkage
[task 2018-11-13T23:32:26.339Z] 23:32:26     INFO -     template<typename _Tp, _Tp __v>
[task 2018-11-13T23:32:26.340Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.340Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:83:3: error: template with C linkage
[task 2018-11-13T23:32:26.340Z] 23:32:26     INFO -     template<typename _Tp, _Tp __v>
[task 2018-11-13T23:32:26.340Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.341Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:92:3: error: template with C linkage
[task 2018-11-13T23:32:26.341Z] 23:32:26     INFO -     template<bool __v>
[task 2018-11-13T23:32:26.341Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.341Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:103:3: error: template with C linkage
[task 2018-11-13T23:32:26.342Z] 23:32:26     INFO -     template<bool, typename, typename>
[task 2018-11-13T23:32:26.342Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.342Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:106:3: error: template with C linkage
[task 2018-11-13T23:32:26.342Z] 23:32:26     INFO -     template<typename...>
[task 2018-11-13T23:32:26.343Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.343Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:109:3: error: template specialization with C linkage
[task 2018-11-13T23:32:26.343Z] 23:32:26     INFO -     template<>
[task 2018-11-13T23:32:26.343Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.344Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:114:3: error: template with C linkage
[task 2018-11-13T23:32:26.363Z] 23:32:26     INFO -     template<typename _B1>
[task 2018-11-13T23:32:26.363Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.364Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:119:3: error: template with C linkage
[task 2018-11-13T23:32:26.364Z] 23:32:26     INFO -     template<typename _B1, typename _B2>
[task 2018-11-13T23:32:26.364Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.364Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:124:3: error: template with C linkage
[task 2018-11-13T23:32:26.366Z] 23:32:26     INFO -     template<typename _B1, typename _B2, typename _B3, typename... _Bn>
[task 2018-11-13T23:32:26.367Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.368Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:129:3: error: template with C linkage
[task 2018-11-13T23:32:26.369Z] 23:32:26     INFO -     template<typename...>
[task 2018-11-13T23:32:26.370Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.371Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:132:3: error: template specialization with C linkage
[task 2018-11-13T23:32:26.372Z] 23:32:26     INFO -     template<>
[task 2018-11-13T23:32:26.373Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.374Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:137:3: error: template with C linkage
[task 2018-11-13T23:32:26.375Z] 23:32:26     INFO -     template<typename _B1>
[task 2018-11-13T23:32:26.376Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.377Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:142:3: error: template with C linkage
[task 2018-11-13T23:32:26.378Z] 23:32:26     INFO -     template<typename _B1, typename _B2>
[task 2018-11-13T23:32:26.379Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.380Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:147:3: error: template with C linkage
[task 2018-11-13T23:32:26.382Z] 23:32:26     INFO -     template<typename _B1, typename _B2, typename _B3, typename... _Bn>
[task 2018-11-13T23:32:26.383Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.384Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:152:3: error: template with C linkage
[task 2018-11-13T23:32:26.385Z] 23:32:26     INFO -     template<typename _Pp>
[task 2018-11-13T23:32:26.386Z] 23:32:26     INFO -     ^~~~~~~~
[task 2018-11-13T23:32:26.387Z] 23:32:26     INFO -  /builds/worker/workspace/build/src/gcc/include/c++/6.4.0/type_traits:189:3: error: template with C linkage
[task 2018-11-13T23:32:26.388Z] 23:32:26     INFO -     template<typename _Tp>
Flags: needinfo?(mh+mozilla)
Depends on: 1507030
Depends on: 1507032
Flags: needinfo?(mh+mozilla)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/6fc6bdea42a6
Enable wayland support with --enable-default-toolkit=cairo-gtk3. r=mshal
When this landed on comment 6, we noticed an increase in build times for platforms bellow. The backout from comment 7 canceled them.

== Change summary for alert #17572 (as of Tue, 13 Nov 2018 20:55:56 GMT) ==

Regressions:

  4%  build times windows2012-32-noopt debug taskcluster-c4.4xlarge     2,002.13 -> 2,077.30
  3%  build times windows2012-32 debug taskcluster-c4.4xlarge           2,772.13 -> 2,857.66
  3%  build times windows2012-64 debug taskcluster-c4.4xlarge           2,787.57 -> 2,864.06

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=17572
(In reply to Ionuț Goldan [:igoldan], Performance Sheriffing from comment #9)
> When this landed on comment 6, we noticed an increase in build times for
> platforms bellow. The backout from comment 7 canceled them.
> 
> == Change summary for alert #17572 (as of Tue, 13 Nov 2018 20:55:56 GMT) ==
> 
> Regressions:
> 
>   4%  build times windows2012-32-noopt debug taskcluster-c4.4xlarge    
> 2,002.13 -> 2,077.30
>   3%  build times windows2012-32 debug taskcluster-c4.4xlarge          
> 2,772.13 -> 2,857.66
>   3%  build times windows2012-64 debug taskcluster-c4.4xlarge          
> 2,787.57 -> 2,864.06
> 
> For up to date results, see:
> https://treeherder.mozilla.org/perf.html#/alerts?id=17572

On a closer look, these seem more related to bug 1496503. :glandium, could you say which of these 2 bugs is more related to the build time increases on Windows 7 debug?
Investigating regressions from multiple AWS platforms is kinda tricky.
Flags: needinfo?(mh+mozilla)
This bug only touches linux, so it can't affect Windows builds. I could buy bug 1496503, but I'm dubious.
Flags: needinfo?(mh+mozilla)
https://hg.mozilla.org/mozilla-central/rev/6fc6bdea42a6
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Could this break artifact and/or try pushes?

I get tons of errors like this on today's try pushes:
PID 1928 | /builds/worker/workspace/build/application/firefox/xpcshell: error while loading shared libraries: libmozwayland.so: cannot open shared object file: No such file or directory
https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=211942437&revision=c8696ed73419422c0f232b1fa5725198d5fe2ea0

And I don't think it comes from any of my devtools changes.
(In reply to Alexandre Poirot [:ochameau] from comment #13)
> Could this break artifact and/or try pushes?
> 
> I get tons of errors like this on today's try pushes:
> PID 1928 | /builds/worker/workspace/build/application/firefox/xpcshell:
> error while loading shared libraries: libmozwayland.so: cannot open shared
> object file: No such file or directory
> https://treeherder.mozilla.org/#/
> jobs?repo=try&selectedJob=211942437&revision=c8696ed73419422c0f232b1fa5725198
> d5fe2ea0
> 
> And I don't think it comes from any of my devtools changes.

Yes, looks like it comes from this one. As it adds a new library, may you need to rebuild the artifact base?
Assignee: nobody → mh+mozilla
Yeah, this is causing every test job to fail on wptsync pushes as they use artifact builds. Therefore this is a showstopper for me.
Flags: needinfo?(mh+mozilla)
Please open a separate bug.
Flags: needinfo?(mh+mozilla)
Depends on: 1507644
Filed bug 1507644.
You need to log in before you can comment on or make changes to this bug.