If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Chimera not processing url that is passed by another application

VERIFIED FIXED in Chimera0.3

Status

Camino Graveyard
General
--
critical
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: Chris Petersen, Assigned: Brian Ryner (not reading))

Tracking

({regression})

unspecified
Chimera0.3
PowerPC
Mac OS X
regression

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Build: 0.3.0
Platform: Mac OS X 10.1.5
Expected Results: Application should process the url that it recieves
What I got: URL string isn't processed in browser

Steps to reproduce:

1) Specify Chimera 0.3.0 as default web browser
System Preferences - Internet - Web tab. Close System Preferences.

2) In another application like Mail.app and AOL IM, click on a embedded url link
in a message.

3) Chimera should launch but url isn't processed in browser window.
(Reporter)

Comment 1

16 years ago
Works in the latest nightly build (2002-06-07-05) but not in 0.3.0.
(Reporter)

Comment 2

16 years ago
Also works in 0.2.8.
Keywords: regression
(Reporter)

Comment 3

16 years ago
*** Bug 150202 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

16 years ago
I wonder if this should be added to our smoketest list. Probably a good idea...

Comment 5

16 years ago
seeing the same lack of processing with URLs passed from Entourage and Mac
reporter (OS X dockling) - definitely in 0.3 but not in the 0607 nightly
(Reporter)

Comment 6

16 years ago
*** Bug 150367 has been marked as a duplicate of this bug. ***
i wonder if something is messed up/corrupt on bryner's mac, since i can't
imagine this working on the top but not working in what we released on friday.

bryner?
Assignee: saari → bryner
Severity: major → critical
Target Milestone: --- → Chimera0.3

Comment 8

16 years ago
This happened on my machine too, with the public release of 0.3.0. I prompty
went and dl'ed the latest nightly build and the problem was gone. I think that
release drop was a bit flawed as there were a bunch of small problems I found
that were only present in that particular drop... which were all rectified in
the night build that was released that very day.

Comment 9

16 years ago
Curious. Despite Neil's experience to the contrary, I am still seeing this bug
on the latest (06/10) nightly. When I first d/loaded it, I thought the bug was
solved (I'm almost positive I clicked on a link in Entourage and that Chimera
launched and picked up the URL). However, even if it did work, the problem is
definitely back now. If Chimera isn't running it will launch, but just opens a
blank window (I have no home page set). If Chimera is running the URL is not passed

Hope this helps
Peter
(Reporter)

Comment 10

16 years ago
As far as nightly builds go, the problem wasn't occuring in the NB 2002-06-08-05
. However, NB 2002-06-09-18 and NB 2002-06-10-05 have this problem now as described.
(Assignee)

Comment 11

16 years ago
This is probably lossage from the static build, then.  I'll take a look.
Status: NEW → ASSIGNED
(Assignee)

Comment 12

16 years ago
Created attachment 87139 [details] [diff] [review]
enable applescript

Comment 13

16 years ago
Comment on attachment 87139 [details] [diff] [review]
enable applescript

r=sdagley (it's that easy?)
(Assignee)

Comment 14

16 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

16 years ago
Marking verified in the NB 2002-06-11-11.
Status: RESOLVED → VERIFIED

Comment 16

16 years ago
*** Bug 150998 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
THIS IS STILL A PROBLEM IN .4

Build 0.4.0 Milestone
Platform Mac OS X 10.1.5
Reproduceable: Always

to reproduce
1. Set Chimera as Mac OS X default Browser
2. open Sherlock
3. Search for something
4. Open a result.
   Chimera opens and displays page as expected.
5. Command-W (close window)
6. Return to sherlock without quiting Chimera
7. open another search result

Expected Result:
  search result opens

Actual Result:
  Chimera comes to the front but no page opens.
uh, we fixed it _after_ the 0.4 release. if you d/l a nightly build, you'll see
it works.

Comment 19

15 years ago
Sorry, I let my first Confirmed bug go to my head, I'll be more careful next time.
Using nightly build 20030509, this bug has popped up again. My previous build
was 4-18-03 and this problem didn't happen there. Basically, clicking on a link
in another app brings Camino to the front but does nothing else. Dragging an
HTML file to Camino's icon works fine though.
Perhaps this bug needs to be reopened?
Hold off on my last message for a moment. I just realized that AppleScript for
some reason got deleted from my system. If I understand correctly, Camino uses
it to get the URL from the other app? I'll get AppleScript from the Apple Store
tonight and see if that solves the porblem.

Comment 22

15 years ago
> I just realized that AppleScript for some reason got deleted from my system.

AppleScript is a core part of the system. You can't delete it.

> If I understand correctly, Camino uses it to get the URL from the other app?

No, the AppleScript tag was just so Camino would get the events.

> I'll get AppleScript from the Apple Store tonight and see if that solves the
porblem.

You can't buy AppleScript from the Apple Store. It's a core part of the system.
You need to log in before you can comment on or make changes to this bug.