Closed Bug 1501283 Opened Last year Closed Last year

Crash in nsTSubstring<T>::Assign

Categories

(Core :: Networking: DNS, defect, P1, critical)

Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- verified

People

(Reporter: calixte, Assigned: bagder)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, Whiteboard: [necko-triaged][trr])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-2fea2752-d748-481b-8c0c-eba890181023.
=============================================================

Top 10 frames of crashing thread:

0 XUL nsTSubstring<char>::Assign xpcom/string/nsTStringRepr.h:315
1 XUL mozilla::net::TRRService::TRRBlacklist xpcom/string/nsTSubstring.cpp:594
2 XUL mozilla::net::TRRService::CompleteLookup netwerk/dns/TRRService.cpp:679
3 XUL non-virtual thunk to mozilla::net::TRRService::CompleteLookup netwerk/dns/TRRService.cpp
4 XUL mozilla::net::TRR::FailData netwerk/dns/TRR.cpp:940
5 XUL mozilla::net::TRR::OnStopRequest netwerk/dns/TRR.cpp:1039
6 XUL mozilla::net::nsHttpChannel::OnStopRequest netwerk/protocol/http/nsHttpChannel.cpp:7874
7 XUL nsInputStreamPump::OnStateStop netwerk/base/nsInputStreamPump.cpp:706
8 XUL nsInputStreamPump::OnInputStreamReady netwerk/base/nsInputStreamPump.cpp:436
9 XUL nsInputStreamReadyEvent::Run xpcom/io/nsStreamUtils.cpp:102

=============================================================

There are 29 crashes (from 14 installations) in nightly 65 with buildid 20181023100120. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1500549.

[1] https://hg.mozilla.org/mozilla-central/rev?node=1c9f10e217d1
Flags: needinfo?(daniel)
Stupid me. Patch pending.
Assignee: nobody → daniel
Flags: needinfo?(daniel)
Priority: -- → P1
Whiteboard: [necko-triaged][trr]
Duplicate of this bug: 1501287
This fixes the regression caused by bug 1500549.

MozReview-Commit-ID: 3VBvIbrEbDT
Crash Signature: [@ nsTSubstring<T>::Assign] → [@ nsTSubstring<T>::Assign] [@ nsTSubstringTuple<T>::IsDependentOn]
Pushed by daniel@haxx.se:
https://hg.mozilla.org/integration/autoland/rev/94f5958dbd0f
for NS checks we don't have originSuffix r=valentin
https://hg.mozilla.org/mozilla-central/rev/94f5958dbd0f
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
No more crashes since the patch landed.
Status: RESOLVED → VERIFIED
confirmed, the crashes on my end no longer happen.
You need to log in before you can comment on or make changes to this bug.