Closed Bug 1501356 Opened 1 year ago Closed 4 months ago

[translate] Add ability to generate a permalink to a string

Categories

(Webtools :: Pontoon, enhancement, P4)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mathjazz, Assigned: abowler2, Mentored)

References

Details

(Whiteboard: outreachyround19)

Attachments

(2 files)

If you open missings strings, translate them, then share a string URL, it will look like this:
https://pontoon.mozilla.org/de/firefox/all-resources/?status=missing&string=190589

The user that gets it will click on it, but string will not show up in the list, because the URL only lists "missing" strings, and the string got translated.

To mitigate that and similar problems, we should add a feature to generate a permanent link to a string, without any (or at least mutable) queryset parameters.
Duplicate of this bug: 1497412
Maybe the same option (to generate a link) should be there for filters too, without aiming for a specific string. It's possible now to remove the "string" query parameter, but it's not comfortable at all a the user needs to know, how Pontoon URLs work.
thx for opening a separate ticket for this :)

Permalinks are definitely useful for creating bug reports about Pontoon here on bugzilla
Or for discussing something about a string on irc

it would be enough for me to have a button or an input field that returns the following url to me:
https://pontoon.mozilla.org/de/firefox/all-resources/?string=190589
(either by copying it automatically to the clipboard or manually)

though a link to a string page, that doesn't display any other strings of the file in the list on the left, could be nice as well.

Is the id unique across projects or per project?
If it's the first, then this could work as well (to make it shorter):
https://pontoon.mozilla.org/de/?string=190589
Attached image Possible UI

abowler2, a short feature definition as promised: we're looking for a way to share permanent links to strings. Usually it's sufficient to just copy the URL, because it contains the unique string identifier in the string parameter. But it may also contain other parameters (e.g. status filters), and since string status can change over time, we must remove all parameters but the string.

So the link we will generate should be of the form:
https://pontoon.mozilla.org/LOCALE/PROJECT/RESOURCE/?string=ID

How should it work? We could add a "Link" button to the left side of the string navigation bar (Previous/Next) and prettify it the link icon. On click, the link should be copied to clipboard and a notification should be displayed, e.g. "Link copied to clipboard".

If you have alternative UX ideas, I'm all ears. :)

Assignee: nobody → abowler2
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Mentor: m
Whiteboard: outreachyround19
You need to log in before you can comment on or make changes to this bug.