JS to move windows around does not work

VERIFIED DUPLICATE of bug 5995

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 5995
19 years ago
18 years ago

People

(Reporter: Simon Fraser, Assigned: Dan M)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Try the URL above in 4.5, and apprunner. Note that the window moving stuff does
not work correctly in apprunner.

Updated

19 years ago
Assignee: davidm → trudelle
Component: Browser-General → XP Toolkit/Widgets

Comment 1

19 years ago
The problem is that the window location is always (0,0) after the call to get
window bounds. I filed a bug about this earlier but this is good test case.

Updated

19 years ago
Assignee: trudelle → danm

Comment 2

19 years ago
reassigning to danm
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14

Comment 3

18 years ago
Resetting QA contact from leger.
(Assignee)

Comment 4

18 years ago
Now that's an annoying website. Judging from davidm's comments above, this was 
probably fixed when bug 5998 was fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

18 years ago
"probably fixed"? did you test it? compare the results in 4.5 and 5.0, and you'll 
notice that, for one, the small penguin window doesn't move around the screen as 
it should, and the window movement seems about 1/10 the speed.
Status: RESOLVED → REOPENED
(Assignee)

Comment 6

18 years ago
  Damn. No need to be rude.
  OK, I see it behaves differently than it does in Nav 4. But coaxing html source 
from anything on that site is something I haven't managed to do. And I know from 
fixing bug 5998 that JS like this
<input type=button value="moveTo(1,1)" onclick="moveTo(1,1)">
<input type=button value="moveBy(10,5)" onclick="moveBy(10,5)">
<input type=button value="screenX=10" onclick="screenX=10">
works just fine. If you can find out what JS it is that's not working as expected 
and add it to this bug, that'd be just keen. Lacking that, I have no idea what 
it's even trying to do.
Resolution: WORKSFORME → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M14 → M16
(Assignee)

Comment 7

18 years ago
Alright. Got the source myself, thank you. A little time spent with it 
demonstrates that the penguin window's faulty movement has nothing to do with JS 
move, but instead stems from the window's bad initial position. Closing as dupe.

If there are other problems demonstrated at this site that you think might fall 
into my domain, I'd appreciate a specific complaint and a line or two of sample 
JS. That beats pointing me at a whole website and getting all huffy when I 
misguess your intention.


*** This bug has been marked as a duplicate of 5995 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
VERIFY dupe, to clean up a little
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.