Closed Bug 1501590 Opened 2 years ago Closed 2 years ago

[A11Y] No Keyboard focus on the controls while tabbing using default Video player

Categories

(Toolkit :: Video/Audio Controls, defect)

63 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 494175

People

(Reporter: sgudimitla, Unassigned)

Details

(Keywords: access)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

1. Navigate to the video on the page - similar to https://developer.mozilla.org/en-US/docs/Web/HTML/Element/video
2. Using tab to focus on the video 
3. Pressed space to play the video.
4. Then used tab to get the focus on to the player controls 


Actual results:

The focus never goes to player controls though the keyboard shortcuts apply, the user can never get the player controls buttons focus using tabbing.
This works fine on Chrome


Expected results:

User should be able to tab through the player controls and perform actions using keyboard 
This is an Accessibility concern and Firefox should handle this just as Chrome does.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Component: Untriaged → Video/Audio Controls
Keywords: access
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 494175
You need to log in before you can comment on or make changes to this bug.