For minimonth, the popup for years is missing scroll up/down controls

RESOLVED FIXED in 6.7

Status

defect
RESOLVED FIXED
9 months ago
8 months ago

People

(Reporter: MakeMyDay, Assigned: arshad)

Tracking

({regression})

Lightning 6.6

Details

Attachments

(2 attachments, 7 obsolete attachments)

STR:

1. Go to calendar tab
2. Click on the year header (2018) of the minimonth in the upper left corner

Expected:
The popup has controlls at the top and bottom to scroll the year list

Observed:
No such controlls anymore

This affects obviously also other occurrences of the minimonth.

Likely a de-XBL regression.
Bug 1457719. Arshad, this one's for you.
Flags: needinfo?(arshdkhn1)
This is a regression of Bug 1457719. I am very soon going to upload a patch that fixes this.
Flags: needinfo?(arshdkhn1)
Posted patch minimonth-yearpopup.patch (obsolete) — — Splinter Review
For moving years, user need to click as the old behavior of scrolling was replaced with click. For more see - https://bugzilla.mozilla.org/show_bug.cgi?id=1457719 .
Assignee: nobody → arshdkhn1
Attachment #9024418 - Flags: review?(geoff)
Status: NEW → ASSIGNED
Comment on attachment 9024418 [details] [diff] [review]
minimonth-yearpopup.patch

Review of attachment 9024418 [details] [diff] [review]:
-----------------------------------------------------------------

Richard's better for this stuff than I am. I will post a screenshot of the popup on my Linux machine, which shows some issues.
Attachment #9024418 - Flags: review?(geoff) → review?(richard.marti)
Posted image rect24.png —
As you can see, the arrow is dark on a dark background, and I think the button itself is much too big.
Comment on attachment 9024418 [details] [diff] [review]
minimonth-yearpopup.patch

Like by Geoff at Linux under Windows I get the wrong buttons. Inspecting it shows https://searchfox.org/comm-central/search?q=arrowscrollbox%3Anot(%5Bclicktoscroll%3D%22true%22%5D)+%3E+.scrollbutton-up&case=false&regexp=false&path= isn't used.

Now the weird thing: when I add the rules above in messenger.css, also the rules above from scrollbox.css are used.

What I also noticed is, that I now have to click on the scrollbuttons to scroll. On TB 60 it begins to scroll, when I hover the buttons.
Attachment #9024418 - Flags: review?(richard.marti) → review-
(In reply to Richard Marti (:Paenglab) from comment #6)
> Comment on attachment 9024418 [details] [diff] [review]
> minimonth-yearpopup.patch
> 
> Like by Geoff at Linux under Windows I get the wrong buttons. Inspecting it
> shows
> https://searchfox.org/comm-central/
> search?q=arrowscrollbox%3Anot(%5Bclicktoscroll%3D%22true%22%5D)+%3E+.
> scrollbutton-up&case=false&regexp=false&path= isn't used.
> 
> Now the weird thing: when I add the rules above in messenger.css, also the
> rules above from scrollbox.css are used.
> 
> What I also noticed is, that I now have to click on the scrollbuttons to
> scroll. On TB 60 it begins to scroll, when I hover the buttons.

Other weird thing is that there are two control button set. One arrowscrollbox > .scrollbutton-up andthe other inside scrollbox. THis was really confusing while debugging it, the buttons that you see are the ones inside the scrollbox. The click to scroll behavior is the new behavior brought up by bug 1457719 which removes the autorepeatbutton. Maybe in TB60 the autorepeatbutton binding was not removed.
On FX in long bookmark menus it still scrolls when hovering the button.
Ihave also observed when i click multiple times on the arrow and nearby area, an alert/beep sound is made. Don't know why that happens?
Posted patch minimonth-yearpopup.patch (obsolete) — — Splinter Review
Attachment #9024418 - Attachment is obsolete: true
Attachment #9024870 - Flags: review?(richard.marti)
Comment on attachment 9024870 [details] [diff] [review]
minimonth-yearpopup.patch

Review of attachment 9024870 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, much better.

::: calendar/lightning/themes/linux/lightning.css
@@ +116,5 @@
> +menupopup[anonid="years-popup"] .scrollbutton-down {
> +  -moz-appearance: none;
> +  border: 1px solid ThreeDShadow;
> +  padding: 0;
> +}
\ No newline at end of file

Could you add a newline here? Not your fault, it wasn't here before your change.
Attachment #9024870 - Flags: review?(richard.marti) → review+
Posted patch minimonth-yearpopup.patch (obsolete) — — Splinter Review
Attachment #9024870 - Attachment is obsolete: true
Posted patch minimonth-yearpopup.patch (obsolete) — — Splinter Review
Attachment #9024970 - Attachment is obsolete: true
Attachment #9024971 - Flags: review+
Keywords: checkin-needed
Comment on attachment 9024971 [details] [diff] [review]
minimonth-yearpopup.patch

Review of attachment 9024971 [details] [diff] [review]:
-----------------------------------------------------------------

::: calendar/base/content/widgets/minimonth.xml
@@ +127,5 @@
> +          <xul:toolbarbutton class="scrollbutton-down"
> +                             orient="vertical"
> +                             onmouseenter="startScroll('down', 1);"
> +                             onmouseout="stopScroll();"
> +                             oncommand="moveYears('down', 1);"/>

Thanks for taking this. I think you can spare the oncommand calls of moveYears() for both buttons now since these are triggered already by startScroll() with this patch - can you check this?
Posted patch minimonth-yearpopup.patch (obsolete) — — Splinter Review
Attachment #9024971 - Attachment is obsolete: true
Attachment #9025129 - Flags: review+
(In reply to [:MakeMyDay] from comment #14)
> Comment on attachment 9024971 [details] [diff] [review]
> minimonth-yearpopup.patch
> 
> Review of attachment 9024971 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: calendar/base/content/widgets/minimonth.xml
> @@ +127,5 @@
> > +          <xul:toolbarbutton class="scrollbutton-down"
> > +                             orient="vertical"
> > +                             onmouseenter="startScroll('down', 1);"
> > +                             onmouseout="stopScroll();"
> > +                             oncommand="moveYears('down', 1);"/>
> 
> Thanks for taking this. I think you can spare the oncommand calls of
> moveYears() for both buttons now since these are triggered already by
> startScroll() with this patch - can you check this?

done!
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/36660399182d
Fix year popup control buttons for minimonth. r=Paenglab,MakeMyDay
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 6.7
Attachment #9025129 - Flags: approval-calendar-beta?(philipp)
Backout by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/7e28b9f45b19
Backed out changeset 36660399182d for multiple Mozmill failures; r=backout
Failures can be seen here: https://treeherder.mozilla.org/#/jobs?repo=comm-central&selectedJob=211838429&revision=6d676a4a8ef9983a0cd87d3c3bc7410c487a14a4 e.g.

You'll have to adjust how the relevant items are found

[task 2018-11-15T00:35:17.189Z] 00:35:17     INFO -    EXCEPTION: Timeout exceeded for waitForElement Lookup: /id("messengerWindow")/id("tabmail-container")/id("tabmail")/id("tabmail-tabbox")/id("tabpanelcontainer")/id("calendarTabPanel")/id("calendarContent")/id("ltnSidebar")/id("minimonth-pane")/{"align":"center"}/id("calMinimonthBox")/id("calMinimonth")/anon({"anonid":"minimonth-header"})/anon({"anonid":"minmonth-popupset"})/anon({"anonid":"years-popup"})/{"class":"autorepeatbutton-up"}
[task 2018-11-15T00:35:17.190Z] 00:35:17     INFO -      at: utils.js line 396
[task 2018-11-15T00:35:17.191Z] 00:35:17     INFO -         TimeoutError utils.js:396 13
[task 2018-11-15T00:35:17.191Z] 00:35:17     INFO -         waitFor utils.js:452 11
[task 2018-11-15T00:35:17.192Z] 00:35:17     INFO -         MozMillController.prototype.waitFor controller.js:687 3
[task 2018-11-15T00:35:17.193Z] 00:35:17     INFO -         MozMillController.prototype.waitForElement controller.js:701 3
[task 2018-11-15T00:35:17.194Z] 00:35:17     INFO -         goToDate test-calendar-utils.js:266 9
[task 2018-11-15T00:35:17.195Z] 00:35:17     INFO -         testWeeklyUntilRecurrence testWeeklyUntilRecurrence.js:61 5
[task 2018-11-15T00:35:17.196Z] 00:35:17     INFO -         Runner.prototype.wrapper frame.js:584 9
[task 2018-11-15T00:35:17.197Z] 00:35:17     INFO -         Runner.prototype._runTestModule frame.js:654 9
[task 2018-11-15T00:35:17.198Z] 00:35:17     INFO -         Runner.prototype.runTestModule frame.js:700 3
[task 2018-11-15T00:35:17.199Z] 00:35:17     INFO -         Runner.prototype.runTestDirectory frame.js:524 7
[task 2018-11-15T00:35:17.200Z] 00:35:17     INFO -         runTestDirectory frame.js:706 3
[task 2018-11-15T00:35:17.201Z] 00:35:17     INFO -         Bridge.prototype._execFunction server.js:177 10
[task 2018-11-15T00:35:17.201Z] 00:35:17     INFO -         Bridge.prototype.execFunction server.js:181 16
[task 2018-11-15T00:35:17.202Z] 00:35:17     INFO -         Session.prototype.receive server.js:282 3
[task 2018-11-15T00:35:17.203Z] 00:35:17     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3
[task 2018-11-15T00:35:17.204Z] 00:35:17     INFO -  SUMMARY-PASS | testAnnualRecurrence.js::setupModule
[task 2018-11-15T00:35:17.205Z] 00:35:17     INFO -  SUMMARY-PASS | testAnnualRecurrence.js::teardownTest
[task 2018-11-15T00:35:17.206Z] 00:35:17     INFO -  SUMMARY-UNEXPECTED-FAIL | testAnnualRecurrence.js | testAnnualRecurrence.js::testAnnualRecurrence
[task 2018-11-15T00:35:17.207Z] 00:35:17     INFO -    EXCEPTION: Timeout exceeded for waitForElement Lookup: /id("messengerWindow")/id("tabmail-container")/id("tabmail")/id("tabmail-tabbox")/id("tabpanelcontainer")/id("calendarTabPanel")/id("calendarContent")/id("ltnSidebar")/id("minimonth-pane")/{"align":"center"}/id("calMinimonthBox")/id("calMinimonth")/anon({"anonid":"minimonth-header"})/anon({"anonid":"minmonth-popupset"})/anon({"anonid":"years-popup"})/{"class":"autorepeatbutton-up"}
[task 2018-11-15T00:35:17.208Z] 00:35:17     INFO -      at: utils.js line 396
[task 2018-11-15T00:35:17.209Z] 00:35:17     INFO -         TimeoutError utils.js:396 13
[task 2018-11-15T00:35:17.210Z] 00:35:17     INFO -         waitFor utils.js:452 11
[task 2018-11-15T00:35:17.212Z] 00:35:17     INFO -         MozMillController.prototype.waitFor controller.js:687 3
[task 2018-11-15T00:35:17.213Z] 00:35:17     INFO -         MozMillController.prototype.waitForElement controller.js:701 3
[task 2018-11-15T00:35:17.214Z] 00:35:17     INFO -         goToDate test-calendar-utils.js:266 9
[task 2018-11-15T00:35:17.215Z] 00:35:17     INFO -         testAnnualRecurrence testAnnualRecurrence.js:42 5
[task 2018-11-15T00:35:17.216Z] 00:35:17     INFO -         Runner.prototype.wrapper frame.js:584 9
[task 2018-11-15T00:35:17.217Z] 00:35:17     INFO -         Runner.prototype._runTestModule frame.js:654 9
[task 2018-11-15T00:35:17.218Z] 00:35:17     INFO -         Runner.prototype.runTestModule frame.js:700 3
[task 2018-11-15T00:35:17.219Z] 00:35:17     INFO -         Runner.prototype.runTestDirectory frame.js:524 7
[task 2018-11-15T00:35:17.220Z] 00:35:17     INFO -         runTestDirectory frame.js:706 3
[task 2018-11-15T00:35:17.221Z] 00:35:17     INFO -         Bridge.prototype._execFunction server.js:177 10
[task 2018-11-15T00:35:17.221Z] 00:35:17     INFO -         Bridge.prototype.execFunction server.js:181 16
[task 2018-11-15T00:35:17.221Z] 00:35:17     INFO -         Session.prototype.receive server.js:282 3
[task 2018-11-15T00:35:17.222Z] 00:35:17     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3
[task 2018-11-15T00:35:17.223Z] 00:35:17     INFO -  SUMMARY-PASS | testDailyRecurrence.js::setupModule
[task 2018-11-15T00:35:17.224Z] 00:35:17     INFO -  SUMMARY-PASS | testDailyRecurrence.js::teardownTest
[task 2018-11-15T00:35:17.225Z] 00:35:17     INFO -  SUMMARY-UNEXPECTED-FAIL | testDailyRecurrence.js | testDailyRecurrence.js::testDailyRecurrence
[task 2018-11-15T00:35:17.226Z] 00:35:17     INFO -    EXCEPTION: Timeout exceeded for waitForElement Lookup: /id("messengerWindow")/id("tabmail-container")/id("tabmail")/id("tabmail-tabbox")/id("tabpanelcontainer")/id("calendarTabPanel")/id("calendarContent")/id("ltnSidebar")/id("minimonth-pane")/{"align":"center"}/id("calMinimonthBox")/id("calMinimonth")/anon({"anonid":"minimonth-header"})/anon({"anonid":"minmonth-popupset"})/anon({"anonid":"years-popup"})/{"class":"autorepeatbutton-up"}
[task 2018-11-15T00:35:17.227Z] 00:35:17     INFO -      at: utils.js line 396
[task 2018-11-15T00:35:17.227Z] 00:35:17     INFO -         TimeoutError utils.js:396 13
[task 2018-11-15T00:35:17.228Z] 00:35:17     INFO -         waitFor utils.js:452 11
[task 2018-11-15T00:35:17.229Z] 00:35:17     INFO -         MozMillController.prototype.waitFor controller.js:687 3
[task 2018-11-15T00:35:17.230Z] 00:35:17     INFO -         MozMillController.prototype.waitForElement controller.js:701 3
[task 2018-11-15T00:35:17.231Z] 00:35:17     INFO -         goToDate test-calendar-utils.js:266 9
[task 2018-11-15T00:35:17.232Z] 00:35:17     INFO -         testDailyRecurrence testDailyRecurrence.js:50 5
[task 2018-11-15T00:35:17.233Z] 00:35:17     INFO -         Runner.prototype.wrapper frame.js:584 9
[task 2018-11-15T00:35:17.234Z] 00:35:17     INFO -         Runner.prototype._runTestModule frame.js:654 9
[task 2018-11-15T00:35:17.235Z] 00:35:17     INFO -         Runner.prototype.runTestModule frame.js:700 3
[task 2018-11-15T00:35:17.235Z] 00:35:17     INFO -         Runner.prototype.runTestDirectory frame.js:524 7
[task 2018-11-15T00:35:17.236Z] 00:35:17     INFO -         runTestDirectory frame.js:706 3
[task 2018-11-15T00:35:17.237Z] 00:35:17     INFO -         Bridge.prototype._execFunction server.js:177 10
[task 2018-11-15T00:35:17.238Z] 00:35:17     INFO -         Bridge.prototype.execFunction server.js:181 16
[task 2018-11-15T00:35:17.239Z] 00:35:17     INFO -         Session.prototype.receive server.js:282 3
[task 2018-11-15T00:35:17.240Z] 00:35:17     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3
[task 2018-11-15T00:35:17.241Z] 00:35:17     INFO -  SUMMARY-PASS | testLastDayOfMonthRecurrence.js::setupModule
[task 2018-11-15T00:35:17.242Z] 00:35:17     INFO -  SUMMARY-PASS | testLastDayOfMonthRecurrence.js::teardownTest
[task 2018-11-15T00:35:17.243Z] 00:35:17     INFO -  SUMMARY-UNEXPECTED-FAIL | testLastDayOfMonthRecurrence.js | testLastDayOfMonthRecurrence.js::testLastDayOfMonthRecurrence
[task 2018-11-15T00:35:17.244Z] 00:35:17     INFO -    EXCEPTION: Timeout exceeded for waitForElement Lookup: /id("messengerWindow")/id("tabmail-container")/id("tabmail")/id("tabmail-tabbox")/id("tabpanelcontainer")/id("calendarTabPanel")/id("calendarContent")/id("ltnSidebar")/id("minimonth-pane")/{"align":"center"}/id("calMinimonthBox")/id("calMinimonth")/anon({"anonid":"minimonth-header"})/anon({"anonid":"minmonth-popupset"})/anon({"anonid":"years-popup"})/{"class":"autorepeatbutton-up"}
[task 2018-11-15T00:35:17.245Z] 00:35:17     INFO -      at: utils.js line 396
[task 2018-11-15T00:35:17.246Z] 00:35:17     INFO -         TimeoutError utils.js:396 13
[task 2018-11-15T00:35:17.247Z] 00:35:17     INFO -         waitFor utils.js:452 11
[task 2018-11-15T00:35:17.248Z] 00:35:17     INFO -         MozMillController.prototype.waitFor controller.js:687 3
[task 2018-11-15T00:35:17.249Z] 00:35:17     INFO -         MozMillController.prototype.waitForElement controller.js:701 3
[task 2018-11-15T00:35:17.250Z] 00:35:17     INFO -         goToDate test-calendar-utils.js:266 9
[task 2018-11-15T00:35:17.251Z] 00:35:17     INFO -         testLastDayOfMonthRecurrence testLastDayOfMonthRecurrence.js:52 5
[task 2018-11-15T00:35:17.252Z] 00:35:17     INFO -         Runner.prototype.wrapper frame.js:584 9
[task 2018-11-15T00:35:17.253Z] 00:35:17     INFO -         Runner.prototype._runTestModule frame.js:654 9
[task 2018-11-15T00:35:17.254Z] 00:35:17     INFO -         Runner.prototype.runTestModule frame.js:700 3
[task 2018-11-15T00:35:17.255Z] 00:35:17     INFO -         Runner.prototype.runTestDirectory frame.js:524 7
[task 2018-11-15T00:35:17.256Z] 00:35:17     INFO -         runTestDirectory frame.js:706 3
[task 2018-11-15T00:35:17.256Z] 00:35:17     INFO -         Bridge.prototype._execFunction server.js:177 10
[task 2018-11-15T00:35:17.257Z] 00:35:17     INFO -         Bridge.prototype.execFunction server.js:181 16
[task 2018-11-15T00:35:17.258Z] 00:35:17     INFO -         Session.prototype.receive server.js:282 3
[task 2018-11-15T00:35:17.259Z] 00:35:17     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3
[task 2018-11-15T00:35:17.260Z] 00:35:17     INFO -  SUMMARY-PASS | testBiweeklyRecurrence.js::setupModule
[task 2018-11-15T00:35:17.261Z] 00:35:17     INFO -  SUMMARY-PASS | testBiweeklyRecurrence.js::teardownTest
[task 2018-11-15T00:35:17.262Z] 00:35:17     INFO -  SUMMARY-UNEXPECTED-FAIL | testBiweeklyRecurrence.js | testBiweeklyRecurrence.js::testBiweeklyRecurrence
[task 2018-11-15T00:35:17.263Z] 00:35:17     INFO -    EXCEPTION: Timeout exceeded for waitForElement Lookup: /id("messengerWindow")/id("tabmail-container")/id("tabmail")/id("tabmail-tabbox")/id("tabpanelcontainer")/id("calendarTabPanel")/id("calendarContent")/id("ltnSidebar")/id("minimonth-pane")/{"align":"center"}/id("calMinimonthBox")/id("calMinimonth")/anon({"anonid":"minimonth-header"})/anon({"anonid":"minmonth-popupset"})/anon({"anonid":"years-popup"})/{"class":"autorepeatbutton-up"}
[task 2018-11-15T00:35:17.264Z] 00:35:17     INFO -      at: utils.js line 396
[task 2018-11-15T00:35:17.265Z] 00:35:17     INFO -         TimeoutError utils.js:396 13
[task 2018-11-15T00:35:17.266Z] 00:35:17     INFO -         waitFor utils.js:452 11
[task 2018-11-15T00:35:17.267Z] 00:35:17     INFO -         MozMillController.prototype.waitFor controller.js:687 3
[task 2018-11-15T00:35:17.268Z] 00:35:17     INFO -         MozMillController.prototype.waitForElement controller.js:701 3
[task 2018-11-15T00:35:17.269Z] 00:35:17     INFO -         goToDate test-calendar-utils.js:266 9
[task 2018-11-15T00:35:17.270Z] 00:35:17     INFO -         testBiweeklyRecurrence testBiweeklyRecurrence.js:43 5
[task 2018-11-15T00:35:17.270Z] 00:35:17     INFO -         Runner.prototype.wrapper frame.js:584 9
[task 2018-11-15T00:35:17.271Z] 00:35:17     INFO -         Runner.prototype._runTestModule frame.js:654 9
[task 2018-11-15T00:35:17.272Z] 00:35:17     INFO -         Runner.prototype.runTestModule frame.js:700 3
[task 2018-11-15T00:35:17.273Z] 00:35:17     INFO -         Runner.prototype.runTestDirectory frame.js:524 7
[task 2018-11-15T00:35:17.274Z] 00:35:17     INFO -         runTestDirectory frame.js:706 3
[task 2018-11-15T00:35:17.275Z] 00:35:17     INFO -         Bridge.prototype._execFunction server.js:177 10
[task 2018-11-15T00:35:17.276Z] 00:35:17     INFO -         Bridge.prototype.execFunction server.js:181 16
[task 2018-11-15T00:35:17.277Z] 00:35:17     INFO -         Session.prototype.receive server.js:282 3
[task 2018-11-15T00:35:17.278Z] 00:35:17     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3
[task 2018-11-15T00:35:17.279Z] 00:35:17     INFO -  SUMMARY-PASS | testWeeklyNRecurrence.js::setupModule
[task 2018-11-15T00:35:17.281Z] 00:35:17     INFO -  SUMMARY-PASS | testWeeklyNRecurrence.js::teardownTest
[task 2018-11-15T00:35:17.281Z] 00:35:17     INFO -  SUMMARY-UNEXPECTED-FAIL | testWeeklyNRecurrence.js | testWeeklyNRecurrence.js::testWeeklyNRecurrence
[task 2018-11-15T00:35:17.282Z] 00:35:17     INFO -    EXCEPTION: Timeout exceeded for waitForElement Lookup: /id("messengerWindow")/id("tabmail-container")/id("tabmail")/id("tabmail-tabbox")/id("tabpanelcontainer")/id("calendarTabPanel")/id("calendarContent")/id("ltnSidebar")/id("minimonth-pane")/{"align":"center"}/id("calMinimonthBox")/id("calMinimonth")/anon({"anonid":"minimonth-header"})/anon({"anonid":"minmonth-popupset"})/anon({"anonid":"years-popup"})/{"class":"autorepeatbutton-up"}
[task 2018-11-15T00:35:17.283Z] 00:35:17     INFO -      at: utils.js line 396
[task 2018-11-15T00:35:17.284Z] 00:35:17     INFO -         TimeoutError utils.js:396 13
[task 2018-11-15T00:35:17.285Z] 00:35:17     INFO -         waitFor utils.js:452 11
[task 2018-11-15T00:35:17.286Z] 00:35:17     INFO -         MozMillController.prototype.waitFor controller.js:687 3
[task 2018-11-15T00:35:17.287Z] 00:35:17     INFO -         MozMillController.prototype.waitForElement controller.js:701 3
[task 2018-11-15T00:35:17.288Z] 00:35:17     INFO -         goToDate test-calendar-utils.js:266 9
[task 2018-11-15T00:35:17.289Z] 00:35:17     INFO -         testWeeklyNRecurrence testWeeklyNRecurrence.js:58 5
[task 2018-11-15T00:35:17.290Z] 00:35:17     INFO -         Runner.prototype.wrapper frame.js:584 9
[task 2018-11-15T00:35:17.291Z] 00:35:17     INFO -         Runner.prototype._runTestModule frame.js:654 9
[task 2018-11-15T00:35:17.292Z] 00:35:17     INFO -         Runner.prototype.runTestModule frame.js:700 3
[task 2018-11-15T00:35:17.293Z] 00:35:17     INFO -         Runner.prototype.runTestDirectory frame.js:524 7
[task 2018-11-15T00:35:17.293Z] 00:35:17     INFO -         runTestDirectory frame.js:706 3
[task 2018-11-15T00:35:17.294Z] 00:35:17     INFO -         Bridge.prototype._execFunction server.js:177 10
[task 2018-11-15T00:35:17.295Z] 00:35:17     INFO -         Bridge.prototype.execFunction server.js:181 16
[task 2018-11-15T00:35:17.296Z] 00:35:17     INFO -         Session.prototype.receive server.js:282 3
[task 2018-11-15T00:35:17.297Z] 00:35:17     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3
[task 2018-11-15T00:35:17.298Z] 00:35:17     INFO -  SUMMARY-PASS | testWeeklyWithExceptionRecurrence.js::setupModule
[task 2018-11-15T00:35:17.299Z] 00:35:17     INFO -  SUMMARY-PASS | testWeeklyWithExceptionRecurrence.js::teardownTest
[task 2018-11-15T00:35:17.300Z] 00:35:17     INFO -  SUMMARY-UNEXPECTED-FAIL | testWeeklyWithExceptionRecurrence.js | testWeeklyWithExceptionRecurrence.js::testWeeklyWithExceptionRecurrence
[task 2018-11-15T00:35:17.301Z] 00:35:17     INFO -    EXCEPTION: Timeout exceeded for waitForElement Lookup: /id("messengerWindow")/id("tabmail-container")/id("tabmail")/id("tabmail-tabbox")/id("tabpanelcontainer")/id("calendarTabPanel")/id("calendarContent")/id("ltnSidebar")/id("minimonth-pane")/{"align":"center"}/id("calMinimonthBox")/id("calMinimonth")/anon({"anonid":"minimonth-header"})/anon({"anonid":"minmonth-popupset"})/anon({"anonid":"years-popup"})/{"class":"autorepeatbutton-up"}
[task 2018-11-15T00:35:17.301Z] 00:35:17     INFO -      at: utils.js line 396
[task 2018-11-15T00:35:17.302Z] 00:35:17     INFO -         TimeoutError utils.js:396 13
[task 2018-11-15T00:35:17.302Z] 00:35:17     INFO -         waitFor utils.js:452 11
[task 2018-11-15T00:35:17.304Z] 00:35:17     INFO -         MozMillController.prototype.waitFor controller.js:687 3
[task 2018-11-15T00:35:17.304Z] 00:35:17     INFO -         MozMillController.prototype.waitForElement controller.js:701 3
[task 2018-11-15T00:35:17.306Z] 00:35:17     INFO -         goToDate test-calendar-utils.js:266 9
[task 2018-11-15T00:35:17.306Z] 00:35:17     INFO -         testWeeklyWithExceptionRecurrence testWeeklyWithExceptionRecurrence.js:67 5
[task 2018-11-15T00:35:17.308Z] 00:35:17     INFO -         Runner.prototype.wrapper frame.js:584 9
[task 2018-11-15T00:35:17.308Z] 00:35:17     INFO -         Runner.prototype._runTestModule frame.js:654 9
[task 2018-11-15T00:35:17.309Z] 00:35:17     INFO -         Runner.prototype.runTestModule frame.js:700 3
[task 2018-11-15T00:35:17.309Z] 00:35:17     INFO -         Runner.prototype.runTestDirectory frame.js:524 7
[task 2018-11-15T00:35:17.311Z] 00:35:17     INFO -         runTestDirectory frame.js:706 3
[task 2018-11-15T00:35:17.311Z] 00:35:17     INFO -         Bridge.prototype._execFunction server.js:177 10
[task 2018-11-15T00:35:17.311Z] 00:35:17     INFO -         Bridge.prototype.execFunction server.js:181 16
[task 2018-11-15T00:35:17.312Z] 00:35:17     INFO -         Session.prototype.receive server.js:282 3
[task 2018-11-15T00:35:17.313Z] 00:35:17     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3
[task 2018-11-15T00:35:17.313Z] 00:35:17  WARNING -  TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
Attachment #9025129 - Flags: approval-calendar-beta?(philipp)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Posted patch minimonth-yearpopup.patch (obsolete) — — Splinter Review
Attachment #9025129 - Attachment is obsolete: true
Posted patch minimonth-yearpopup.patch (obsolete) — — Splinter Review
Attachment #9025591 - Attachment is obsolete: true
Attachment #9025900 - Flags: review+
Comment on attachment 9025900 [details] [diff] [review]
minimonth-yearpopup.patch

Review of attachment 9025900 [details] [diff] [review]:
-----------------------------------------------------------------

::: calendar/base/content/widgets/minimonth.xml
@@ +111,5 @@
>                         onpopupshowing="moveYears('reset', 0); event.stopPropagation();"
>                         onpopuphidden="firePopupListHidden();">
> +          <xul:toolbarbutton class="scrollbutton-up"
> +                             orient="vertical"
> +                             oncommand="moveYears('up', 1);"

Command event handler is necessary for tests.
Umm, the try is pretty red or is that fixed in the latest version?
(In reply to Jorg K (GMT+1) from comment #24)
> Umm, the try is pretty red or is that fixed in the latest version?

running the try run for latest version.. but first for linux only to save time? It passes on my mac.
I'm not sure why you did another try run. Was it with the same patch? Had you rebased locally, all the test failures you're seeing would have gone already, see bug 1507537 where I disabled them.
(In reply to Jorg K (GMT+1) from comment #28)
> I'm not sure why you did another try run. Was it with the same patch? Had
> you rebased locally, all the test failures you're seeing would have gone
> already, see bug 1507537 where I disabled them.

Jorg, I did another try run for the osx as well..
Attachment #9025900 - Attachment is obsolete: true
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/4401f585b168
Fix year popup control buttons for minimonth. r=Paenglab,MakeMyDay DONTBUILD
Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.