Closed Bug 1501622 Opened Last year Closed Last year

CSS variable tooltip shows duplicated value

Categories

(DevTools :: Inspector: Rules, defect, P2)

defect

Tracking

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 verified, firefox65 verified)

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- verified
firefox65 --- verified

People

(Reporter: jdescottes, Assigned: jdescottes)

References

Details

(Keywords: regression)

Attachments

(4 files)

Regression in Firefox 64.

STRs:
- open any page with CSS variables (eg about:debugging)
- open inspector, rule view, 
- hover on a CSS variable several times to show the variable value tooltip

=> The tooltip content keeps listing the same value again and again.

See attached GIF
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Depends on D9648

Note that this is not strictly necessary since the set* methods are only called when
the Swatch tooltips are built, so they always operate on "new" HTML Tooltips. But 
since this is not very self explanatory I think it will be less surprising to be
on the safe side and clear innerHTML in the methods directly.
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/43ce349e1566
Cleanup CSS variable preview tooltip content when hovering new variable;r=pbro
https://hg.mozilla.org/integration/autoland/rev/664384a424ed
For consistency, clear innerHTML in SwatchTooltips;r=pbro
Reminder to request beta uplift once this is on central.
Flags: needinfo?(jdescottes)
Duplicate of this bug: 1501485
https://hg.mozilla.org/mozilla-central/rev/43ce349e1566
https://hg.mozilla.org/mozilla-central/rev/664384a424ed
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Flags: qe-verify+
Flags: in-testsuite+
[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1472942

User impact if declined: CSS preview variable shows duplicated values

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): simple javascript one liner

String changes made/needed: none
Flags: needinfo?(jdescottes)
Attachment #9019933 - Flags: review+
Attachment #9019933 - Flags: approval-mozilla-beta?
See Also: → 1501918
I successfully reproduced the issue on Firefox Nightly 65.0a1 (2018-10-23) under Windows 10 (x64) using the STR from Comment 0.

The issue is no longer reproducible on latest Nightly 65.0a1 (2018-10-24) under Windows 10 (x64), Ubuntu 16.04 (x64) and macOS 10.12.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Comment on attachment 9019933 [details] [diff] [review]
bug-1501622-beta-patch

Simple fix for a devtools regression with an automated test included. Approved for 64.0b4.
Attachment #9019933 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
The issue is verified fix on Firefox Beta 64.0b4 under Windows 10 (x64), Ubuntu 16.04 (x64) and macOS 10.12.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.