Closed Bug 1501627 Opened Last year Closed Last year

Crash in webrender::renderer::Renderer::draw_tile_frame

Categories

(Core :: Graphics: WebRender, defect, P1, critical)

Unspecified
All
defect

Tracking

()

VERIFIED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- fixed

People

(Reporter: djc, Assigned: bholley)

References

(Blocks 3 open bugs)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-09b0c9b4-fcd5-45dd-b96f-f3ad20181024.
=============================================================

Top 10 frames of crashing thread:

0 libmozglue.dylib mozalloc_abort memory/mozalloc/mozalloc_abort.cpp:35
1 libmozglue.dylib abort memory/mozalloc/mozalloc_abort.cpp:82
2 XUL panic_abort::__rust_start_panic::abort src/libpanic_abort/lib.rs:61
3 XUL __rust_start_panic src/libpanic_abort/lib.rs:56
4 XUL std::panicking::rust_panic_with_hook src/libstd/panicking.rs:523
5 XUL std::panicking::begin_panic src/libstd/panicking.rs:409
6 XUL webrender::renderer::Renderer::draw_tile_frame gfx/webrender/src/tiling.rs:308
7 XUL webrender::renderer::Renderer::render_impl gfx/webrender/src/renderer.rs:2591
8 XUL wr_renderer_render gfx/webrender/src/renderer.rs:2476
9 XUL mozilla::wr::RenderThread::UpdateAndRender gfx/webrender_bindings/RendererOGL.cpp:146

=============================================================

Happened while scrolling a YouTube video page (in theater mode), on an late 2013 rMBP with integrated Iris graphics.
Socorro mentions bug 1442921 as related, but since that was fixed months ago, I assumed this was worth filing.
This is probably the same as bug 1501518. The fix is already on autoland.
Depends on: 1501518
There are 50 crashes (from 15 installations) in nightly 65 with buildid 20181024100114. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1501319.

[1] https://hg.mozilla.org/mozilla-central/rev?node=61b89032c551
I asked the sheriffs to merge the fix and spin another nightly so hopefully you'll be able to update to a non-crashing build soon.
Blocks: wr-stability
OS: Mac OS X → All
Priority: -- → P1
The nightly channel should have a build with the fix now. Can you update and retest?
Flags: needinfo?(dirkjan)
It happened with fullscreen videos on YouTube and is fixed with 20181024133237.
When I tried earlier, I wasn't able to reproduce this deterministically (in fact, I didn't reproduce it even once after the initial crash), so not sure I can help here.
Flags: needinfo?(dirkjan)
Ok, seems like it should be safe to mark fixed. If anybody hits it again please let us know.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Assignee: nobody → bobbyholley
Target Milestone: --- → mozilla65
No crashes on 10-25 or later builds.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.