Closed Bug 1501797 Opened 10 months ago Closed 10 months ago

Responsive view resets everytime

Categories

(DevTools :: Responsive Design Mode, defect)

63 Branch
Unspecified
All
defect
Not set

Tracking

(firefox63 affected, firefox64 unaffected, firefox65 unaffected)

RESOLVED DUPLICATE of bug 1248619
Tracking Status
firefox63 --- affected
firefox64 --- unaffected
firefox65 --- unaffected

People

(Reporter: mastafu, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.67 Safari/537.36

Steps to reproduce:

Everytime I enter Responsive View, the view resets to the smallest preset, which is 320px. Many versions ago, Firefox remembered last used preset.



Actual results:

Go to responsive view, smallest preset is selected. Exit, do it again, and smallest is selected again.


Expected results:

Last used preset should be selected.
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Hi reporter, 

Thank you for taking the time to add this report.

I was able to reproduce the issue that you mention on the latest 63 Release build(20181018182531) on Windows 10 and 7, Ubuntu 18.04 and MacOSX. If I change the size of the viewport and then close the Responsive Design Mode, whenever I enter Responsive View again, the viewport is back to the default size rather than the last state(size).

This behavior is not present in the latest DevEdition Build (20181022150107) or latest Nightly build (20181025100246), therefore, I'm assuming this might be a known issue that I might not have found, but I'll assign this to DevTools:Responsive Design Mode component, so that someone more advised can handle this.
Status: UNCONFIRMED → NEW
Component: Untriaged → Responsive Design Mode
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → DevTools
Great, would love to have it fixed ASAP :) It's been ages since this bug started in Dev tools. And it is rather annoying one :)
One more thing. Would you change position of device selection, from left to center, as it was before?
With large monitors it is rather bad UX. It should be with the rest of the RWD view settings. In the center, where my viewport is.
Now I have to look around and travel to distance places on the brink of my monitor :)
Hi, this bug was already reported and is taken care of.  I will close this report as duplicate, but feel free to reopen it if you feel the issue is not addressed in bug 1248619.
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1248619
You need to log in before you can comment on or make changes to this bug.