Closed Bug 1501809 Opened 11 months ago Closed 11 months ago

raptor tp6 'main application timed out after 30 seconds' when running 1 pagecycle

Categories

(Testing :: Raptor, defect)

Version 3
defect
Not set

Tracking

(firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: rwood, Assigned: rwood)

References

Details

Attachments

(1 file)

When running Raptor locally on OSX against Firefox or Chrome, this message shows up during the 30 second pause. WHY? Not seeing this in production, and it doesn't effect the test - the Raptor test still runs and finishes.

15:25:57     INFO -  raptor-control-server received webext_status: * pausing 30 seconds to let browser settle... *
15:26:22     INFO -  raptor-main application timed out after 30 seconds
I'm only seeing this when running with 1 pagecycle that's why it's not showing up in production, and it is stopping the test from finishing (originally thought it was finishing).

So the problem is that the main Raptor timeout [1] is not accounting for the browser startup pause inside the Raptor webext runner [2]. So with 1 pagecycle the main timeout is happening because of the startup pause (30 seconds). The startup pause [2] has to be added to the main timeout value [1].

[1] https://searchfox.org/mozilla-central/rev/72b1e834f384a2ffec6eb4ce405fbd4b5e881109/testing/raptor/raptor/raptor.py#234

[2] https://searchfox.org/mozilla-central/rev/72b1e834f384a2ffec6eb4ce405fbd4b5e881109/testing/raptor/webext/raptor/runner.js#20
Summary: raptor-main application timed out after 30 seconds → raptor tp6 'main application timed out after 30 seconds' when running 1 pagecycle
While fixing this I'm going to move the 'post-startup-delay' value set outside the webext in raptor.py, and passed into the webext runner.js via gen_test_config.

Having this value set in raptor.py is better, so that in future patches the startup delay could be changed by a new command line argument or in a raptor debug mode (Bug 1470450).
Assignee: nobody → rwood
Blocks: 1470450
Status: NEW → ASSIGNED
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8c16d6956679
Fix Raptor tp6 'main application timed out'; r=jmaher
https://hg.mozilla.org/mozilla-central/rev/8c16d6956679
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.