Closed Bug 1501832 Opened 1 year ago Closed 1 year ago

fritzbox admin pages (FritzOS 06.83) are not shown correctly with Firefox 60.2.2esr

Categories

(Firefox :: Untriaged, defect)

60 Branch
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: michaelof, Unassigned)

Details

Attachments

(3 files)

Attached image Firefox.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

Opened my routers admin pages in Firefox. Tried to open a port in firewall.


Actual results:

Dialogue is unusable in Firefox. Tried in Chromium, works fine.
Screenshots appended
We need a testcase attached as html or a public URL.
Flags: needinfo?(michaelof)
As this problem happens on private router's admin pages, a public URL might be not the best idea :-)

Started the page where the problem exists, screenshot uploaded before. Saved page as "Webpage, complete" from Firefox. Zipped .html and .js etc. from subdir into one zip file.

I just recognized that Firefox only shows the error when in "real life" mode, connected to the router's admin page. When opening just the saved html, "popup" is shown as it should.
Flags: needinfo?(michaelof)
Can you please try the Firefox safemode just to be sure that no extension is causing this:
- https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

There should not be a difference if you load the html from local or via a webserver.
https://mversen.de/temp/FRITZ!Box%20Fon%20WLAN%207390.html works for me as expected.
Unbelievable! 

As the page works fine in safemode, I've started to disable my (few) addons, one by one.

And in fact "Adblock Plus" was the culprit.

Page is only displayed correctly if Adblock Plus is completely disabled, as addon. 
Setting Adblock Plus' page specific option "deactivate on this page" does NOT help, anyway that there are no (blocked) ads on this router's  admin page. Strange ....

But deactivating Adblock Plus as long as I'll set up open ports (not that often :-)) is an acceptable workaround. 

Side effect of this issue is, that I've just recognized that Firefox is now able to deactivate and activate addons on the fly, no restart necessary anymore, nice!

SOLVED, thank you very, very much!
Is the saved version of the Fritzbox page on my webserver working for you with adblock ?
In that case you could try ublock origin instead of adblock because that is what I use and that seems to work.
Another option would be to ask the adblock support for assistance.

>Side effect of this issue is, that I've just recognized that Firefox is now able to deactivate and activate addons on the fly, no 
>restart necessary anymore, nice!
That is a result of moving to the new addon system. The addons have less power and break Firefox much less as in the past.
Your report is of course a rare exception :-)

I will mark this report invalid because this doesn't seem to be a bug in Firefox but rather caused by an extension.
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
(In reply to Matthias Versen [:Matti] from comment #6)
> Is the saved version of the Fritzbox page on my webserver working for you
> with adblock ?

No.

> Another option would be to ask the adblock support for assistance.

Already did: https://adblockplus.org/forum/viewtopic.php?f=1&t=60440
You need to log in before you can comment on or make changes to this bug.