Closed Bug 1501845 Opened Last year Closed Last year

<radiogroup> in migration.xul doesn't work/show selection when shown before browser startup with -migration

Categories

(Toolkit :: XUL Widgets, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- verified
firefox65 --- verified

People

(Reporter: MattN, Assigned: bgrins)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

JavaScript error: chrome://global/content/bindings/radio.xml, line 29: TypeError: control.radioChildConstructed is not a function
This is another case of a document getting loaded before MainProcessSingleton,
similar to profile manager. There's another wrinkle here, though. The migration
UI can also be loaded _after_ startup (through Bookmarks manager), which is
actually the primary way this UI is surfaced. So we need to also handle customElements.js
getting loaded twice into the same window to avoid attempting to redefine everything.
Priority: -- → P2
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8b72cee028cd
Load customElements.js inside migration.xul to fix migration UI when running with commandline;r=paolo
https://hg.mozilla.org/mozilla-central/rev/8b72cee028cd
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Please nominate this for Beta approval when you get a chance.
Flags: needinfo?(bgrinstead)
Status: RESOLVED → VERIFIED
Comment on attachment 9019844 [details]
Bug 1501845 - Load customElements.js inside migration.xul to fix migration UI when running with commandline;r=paolo

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1481949

User impact if declined: This only affects users who run Firefox with the custom `--migration` commandline argument. But if they do, the migration wizard won't work. The usual migration UI through "Bookmarks"->"Import Data From Another Browser" should work with or without this patch.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: 1) Run Nightly with the `--migration` command line argument
2) Create a new profile
3) Click "Start Nightly" - This should open an "import wizard" 

Then there are a few use cases to test (go back to steps 1-3 after each one)

(a) Click Cancel: it should just open Firefox.
(b) Click Firefox: it should take you to a second page that lists the profiles on your computer. If you click "Go back" it should take you back to the first page. If you click continue again it should take you to the profile list. If you select one of the profiles, it should open Firefox with all the bookmarks, history, etc copied from the selected profile.
(c) Click on other browsers. It should start Firefox and with all the bookmarks, history, etc copied from the selected browser.

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It's a small / simple fix. Also, the use case this fixes is not visible without running Firefox with custom command line arguments. The main risk here is that there don't seem to be any automated tests for either the command line use case or the primary use case through the Bookmarks UI. Because of that, I've asked QE to do some manual verification.

String changes made/needed: None
Flags: needinfo?(bgrinstead)
Attachment #9019844 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Comment on attachment 9019844 [details]
Bug 1501845 - Load customElements.js inside migration.xul to fix migration UI when running with commandline;r=paolo

[Triage Comment]
Fixes migration issues when Firefox is launched in some conditions. Approved for 64.0b6.
Attachment #9019844 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Correction to QE steps in Comment 7: I was running with just the `--migration` command, but that's because I've unchecked the "Use selected profile without asking" box in the profile manager in the past. The full command should include `--migration -P` so that it doesn't migrate straight into your default profile. So for example, on OSX the command is:

`/Applications/FirefoxNightly.app/Contents/MacOS/firefox --migration -P`
Hi, I tried reproducing this issue in older versions of Firefox Beta, or Nightly or Release but without any success, every time I use -migration -p I get the profile manager, create the New profile and right after I can select from where to import my history and Bookmarks from which also works well.

I tested this issue on all 3 version of Firefox on Mac OS X, Windows 10 and Ubuntu 18.04, I'm inclined to Mark it as verified but I can't reproduce the issue in the first place.

Is there any build this issue occurs on ?
Flags: needinfo?(bgrinstead)
It has to be one that has bug 1481949 in it. It's possible that the -P option fixes the bug for you so you may need to create the new profile first with -P then exit and launch with that profile name `-migration -P <name>`.
Hi again, using your steps Matthew I did in fact manage to reproduce this issue in Beta 64.0b5, after writing the "path" in terminal -migration -p (profilename) the import Wizard would start but I was unable to select an option to import from, which has been resolved in 64.0b6 and the latest Nightly, I will mark this issue accordingly.
Flags: qe-verify+
Flags: needinfo?(bgrinstead)
(In reply to Rares Doghi from comment #13)
> Hi again, using your steps Matthew I did in fact manage to reproduce this
> issue in Beta 64.0b5, after writing the "path" in terminal -migration -p
> (profilename) the import Wizard would start but I was unable to select an
> option to import from, which has been resolved in 64.0b6 and the latest
> Nightly, I will mark this issue accordingly.

Thanks!
See Also: → 1547463
You need to log in before you can comment on or make changes to this bug.