Identity popup should be labelled by the Site information header for accessibility

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
normal
VERIFIED FIXED
9 months ago
6 months ago

People

(Reporter: Jamie, Assigned: MarcoZ)

Tracking

({access})

Trunk
Firefox 65
Points:
---

Firefox Tracking Flags

(firefox65 verified)

Details

Attachments

(1 attachment)

STR (with the NVDA screen reader):
1. Open google.com.
2. Press alt+d to focus the address bar.
3. Press shift+tab to focus the View site information button.
4. Press space to activate it.
Expected: NVDA should say "Site Information for www.google.com  dialog"...
Actual: NVDA says "dialog"... (the "Site Information for" bit is missing)

The Site Information header added in bug 1476220 (id: identity-popup-mainView-panel-header-span) should label the popup (id: identity-popup) for accessibility purposes. This popup didn't previously have an accessibility label because there wasn't an obvious label, but now that there is, it makes sense to label it. This can be done simply by adding aria-labelledby="identity-popup-mainView-panel-header-span" to #identity-popup.
Assignee: nobody → mzehe
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by mzehe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fdb31d77a4e9
Label the Identity popup with the Site information header for accessibility, r=johannh
https://hg.mozilla.org/mozilla-central/rev/fdb31d77a4e9
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Flags: qe-verify+

I have reproduced this issue using Firefox .0a1 65.0a1 (2018.10.24)on Win 10 x64.
I can confirm this issue is fixed, I verified using Firefox 65.0 Win 10 x64, Ubuntu 16.04 x64 and Mac OS X 10.13.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.