Closed Bug 1502006 Opened 2 years ago Closed 2 years ago

Android 4.0 API16+ opt l10n repacks broken

Categories

(Firefox Build System :: General, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1483190

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: dvarga [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=207746168&repo=mozilla-central

https://queue.taskcluster.net/v1/task/KHnuR4LOQ6aD6exwPzuT7w/runs/0/artifacts/public/logs/live_backing.log

Latest nightly push: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&selectedJob=207746168&revision=3cc04ee79005058d817daf66da7963dfac3f0a3a

[task 2018-10-25T11:20:00.669Z] 11:20:00     INFO -   0:02.60 checking for vcs source checkout... hg
[task 2018-10-25T11:20:00.899Z] 11:20:00     INFO -   0:02.83 checking for a shell... /usr/bin/sh
[task 2018-10-25T11:20:00.935Z] 11:20:00     INFO -   0:02.87 checking for host system type... x86_64-pc-linux-gnu
[task 2018-10-25T11:20:00.942Z] 11:20:00     INFO -   0:02.88 checking for target system type... arm-unknown-linux-androideabi
[task 2018-10-25T11:20:00.998Z] 11:20:00     INFO -   0:02.93 checking for a shell... /usr/bin/sh
[task 2018-10-25T11:20:01.034Z] 11:20:01     INFO -   0:02.97 checking for host system type... x86_64-pc-linux-gnu
[task 2018-10-25T11:20:01.042Z] 11:20:01     INFO -   0:02.98 checking for target system type... arm-unknown-linux-androideabi
[task 2018-10-25T11:20:01.090Z] 11:20:01     INFO -   0:03.03 checking whether cross compiling... yes
[task 2018-10-25T11:20:01.158Z] 11:20:01     INFO -   0:03.09 checking for vcs source checkout... hg
[task 2018-10-25T11:20:01.159Z] 11:20:01    ERROR -   0:03.10 Traceback (most recent call last):
[task 2018-10-25T11:20:01.159Z] 11:20:01     INFO -   0:03.10   File "/builds/worker/workspace/build/src/configure.py", line 123, in <module>
[task 2018-10-25T11:20:01.160Z] 11:20:01     INFO -   0:03.10     sys.exit(main(sys.argv))
[task 2018-10-25T11:20:01.160Z] 11:20:01     INFO -   0:03.10   File "/builds/worker/workspace/build/src/configure.py", line 29, in main
[task 2018-10-25T11:20:01.160Z] 11:20:01     INFO -   0:03.10     sandbox.run(os.path.join(os.path.dirname(__file__), 'moz.configure'))
[task 2018-10-25T11:20:01.161Z] 11:20:01     INFO -   0:03.10   File "/builds/worker/workspace/build/src/python/mozbuild/mozbuild/configure/__init__.py", line 434, in run
[task 2018-10-25T11:20:01.161Z] 11:20:01     INFO -   0:03.10     self._value_for(option)
[task 2018-10-25T11:20:01.161Z] 11:20:01     INFO -   0:03.10   File "/builds/worker/workspace/build/src/python/mozbuild/mozbuild/configure/__init__.py", line 502, in _value_for
[task 2018-10-25T11:20:01.162Z] 11:20:01     INFO -   0:03.10     return self._value_for_option(obj)
[task 2018-10-25T11:20:01.162Z] 11:20:01     INFO -   0:03.10   File "/builds/worker/workspace/build/src/python/mozbuild/mozbuild/util.py", line 944, in method_call
[task 2018-10-25T11:20:01.162Z] 11:20:01     INFO -   0:03.10     cache[args] = self.func(instance, *args)
[task 2018-10-25T11:20:01.162Z] 11:20:01     INFO -   0:03.10   File "/builds/worker/workspace/build/src/python/mozbuild/mozbuild/configure/__init__.py", line 567, in _value_for_option
[task 2018-10-25T11:20:01.162Z] 11:20:01     INFO -   0:03.10     % option_string.split('=', 1)[0])
[task 2018-10-25T11:20:01.163Z] 11:20:01     INFO -   0:03.10 mozbuild.configure.options.InvalidOptionError: --enable-lto is not available in this configuration
[task 2018-10-25T11:20:01.196Z] 11:20:01     INFO -   0:03.13 *** Fix above errors and then restart with\
[task 2018-10-25T11:20:01.196Z] 11:20:01     INFO -   0:03.13                "./mach build"
[task 2018-10-25T11:20:01.196Z] 11:20:01     INFO -   0:03.13 client.mk:111: recipe for target 'configure' failed
[task 2018-10-25T11:20:01.197Z] 11:20:01     INFO -   0:03.13 make: *** [configure] Error 1
[task 2018-10-25T11:20:01.253Z] 11:20:01    ERROR - Return code: 2
[task 2018-10-25T11:20:01.253Z] 11:20:01    FATAL - Configure failed!
[task 2018-10-25T11:20:01.253Z] 11:20:01    FATAL - Running post_fatal callback...
[task 2018-10-25T11:20:01.253Z] 11:20:01    FATAL - Exiting -1
Flags: needinfo?(mh+mozilla)
This is in an l10n repack, and it's because the repacks use --disable-compile-environment.
Summary: Android Android 4.0 API16+ opt nightlies broken - Intermittent 0:03.10 Traceback (most recent call last): → Android 4.0 API16+ opt l10n repacks broken
@dvarga, why am I cc-d on this ? I have no idea what it is about. I didn't even know I had an account here :-D
(In reply to pike from comment #2)
> @dvarga, why am I cc-d on this ? I have no idea what it is about. I didn't
> even know I had an account here :-D

I think you were mistaken for long-time l10n guru Axel Hecht, also known as :pike.
Flags: needinfo?(l10n)
`. "$topsrcdir/mobile/android/config/mozconfigs/android-api-16/nightly"` is in l10n-nightly. Probably needs to split the nightly config into something compile-independent, and include that from both nightly and l10n-nightly?
Flags: needinfo?(l10n)
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mh+mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1483190
You need to log in before you can comment on or make changes to this bug.