Closed Bug 1502096 Opened 2 years ago Closed 2 years ago

Previewing and selecting the default theme work inconsistently in Dark mode

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- wontfix
firefox64 --- verified
firefox65 --- verified

People

(Reporter: dao, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(1 file)

from bug 1501373:

> 4. Hovering over the "Default" theme in the customization window displays
> the expected results, but then it reverts back to all black when selected.
Priority: -- → P1
Flags: qe-verify+
Keywords: regression
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/20e04b1355dc
Make peviewing and selecting the default theme work consistently in Dark mode. r=spohl
https://hg.mozilla.org/mozilla-central/rev/20e04b1355dc
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Comment on attachment 9020197 [details]
Bug 1502096 - Make peviewing and selecting the default theme work consistently in Dark mode. r?spohl

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1466335

User impact if declined: Preview of the default theme is confusing in dark mode

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Enable dark mode in Windows 10 / macOS Mojave, enter customize mode, select a non-default Firefox theme from the theme dropdown, hover over the default theme.

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Very straightforward fix

String changes made/needed:
Attachment #9020197 - Flags: approval-mozilla-beta?
There's a typo, _substituteDefaulThemeIfNeeded is missing a `t` between Defaul and Theme.
Can we get a follow-up for the typo in comment 6?
Flags: needinfo?(dao+bmo)
The function definition and call sites are consistent, so this is good to go to beta.
Flags: needinfo?(dao+bmo)
Comment on attachment 9020197 [details]
Bug 1502096 - Make peviewing and selecting the default theme work consistently in Dark mode. r?spohl

[Triage Comment]
Taking this in 64.0b5, but I'd still like to see the follow-up bug filed before we forget about it.
Attachment #9020197 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Hi,

I've reproduced the issue on latest Release 63.0 Build ID:20181018182531 on Win10 x64 and macOS 10.14 Mojave.

I couldn't reproduce the issue on the latest Nightly 65.0a1 Build ID:20181029100347 nor on Win10 or macOS 10.14. Marking as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1502974
Hi,

I checked again and couldn't reproduce the issue on the latest Beta 64.0b5 Build ID:20181029164536 nor on Win10 or macOS 10.14. Marking as verified fixed.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.