Bug 1502171 (AS-lint-in-mc)

turning on linting of Activity-Stream code in mozilla-central

RESOLVED DUPLICATE of bug 1553917

Status

()

enhancement
P3
normal
RESOLVED DUPLICATE of bug 1553917
9 months ago
9 days ago

People

(Reporter: dmose, Unassigned)

Tracking

(Depends on 1 bug, Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

User Story

As a mozilla-central developer, any changes I make to browser/components/newtab should be linted like other parts of m-c, so that key style & defect types are caught/fixed more efficiently.
After eslint gets vendored into mozilla-central, we'll want to land our own specific eslint plugins there as well, so that we can then remove activity-stream from the top-level .eslintignore and have it get first-class linting support in-tree.

There was some discussion about wanting in-tree unit-testing as a prerequisite, so that broad changes are less-likely to introduce issues that should have been caught.
Iteration: --- → 65.2 (Nov 16)
Priority: -- → P2
Iteration: 65.2 (Nov 16) → 65.3 (Nov 30)
Iteration: 65.3 (Nov 30) → 65.4 - Dec 3-9
Iteration: 65.4 - Dec 3-9 → ---
Priority: P2 → P3
Component: Activity Streams: Newtab → Messaging System
Status: NEW → RESOLVED
Closed: 9 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1553917
You need to log in before you can comment on or make changes to this bug.