Inbox Folder of IMAP Account Cleared

RESOLVED INVALID

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED INVALID
16 years ago
10 years ago

People

(Reporter: Kevin Chen, Assigned: Scott MacGregor)

Tracking

({dataloss})

Trunk
x86
Windows 98
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

Recently, my Internet has been going out quite frequently.

Now, I use Mozilla to get my IMAP mail.  I usually leave the mail window open on
the Inbox folder throughout the day.  Mozilla is set to retrieve mail every 1
minute.

It appears, though, that when my Internet connection gets dropped, that when it
reconnects, all of my mail is deleted.  My inbox is completely empty.  When I
check the same account through webmail (http://webmail.mit.edu/), my inbox is
also completely empty, and there are no messages to undelete.  The messages
previously in my inbox are also not in the trash folder.

I do, however, have several folders besides Inbox in my IMAP account.  Those
folders all retain their contents.

Now I am not 100% sure that this is Mozilla's fault, but it appears to be.  This
has happened a few times over the past few months.

Reproducible: Didn't try
Steps to Reproduce:
I haven't actually tried this, but I would expect this would work:

1. Setup an IMAP account.
2. Set Mozilla to check for mail every 1 minute.
3. Open the Inbox.
4. Disconnect your Internet for 5-10 minutes.
5. Reconnect your Internet connection.
6. Attempt to read mail.

Actual Results:  Inbox cleared.

Expected Results:  Retain Inbox messages.
(Reporter)

Updated

16 years ago
Keywords: dataloss
Summary: Inbox Folder of IMAP Account → Inbox Folder of IMAP Account
(Reporter)

Updated

16 years ago
Summary: Inbox Folder of IMAP Account → Inbox Folder of IMAP Account Cleared
(Reporter)

Comment 1

16 years ago
Never mind...I just realized what the problem was.

I was running the pine mail program on an SSH connection, and I didn't realize
it was downloading all the messages and deleting them...

Marking INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Updated

16 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.