glossary is not saved on exit

RESOLVED FIXED

Status

Mozilla Localizations Graveyard
MozillaTranslator
RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: Tsahi Asher, Assigned: Henrik Lynggaard Hansen)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:

BuildID:    5beta8b

sometimes the glossary file is not saved correctly when selecting Yes in the
exit dialog, resulting in loss of work done

Reproducible: Sometimes
Steps to Reproduce:
1. make changes in the translation (translate some words or add a product)
2. choose File > exit
3. select Yes in the dialog
4. start MT again


Actual Results:  changes are not saved, and work done since last successful save
is lost

Expected Results:  glossary should be saved correctly

Comment 1

16 years ago
I have experienced this too. But *deleting* the glossary.zip file before saving
(of course, keep at least one backup!) seems to help.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

16 years ago
Whiteboard: target=beta-9

Comment 2

16 years ago
I epirienced the same today. This is not funny.
Is there a fix ahead?

Gunner Poulsen
(Assignee)

Comment 3

16 years ago
I can't sreproduce this on either my windows system or my linux system.

I need more information:
* when does this happen ?
* what system and JDK are MT being run on ?
* how are the products setup ?

if it reproducable for one of you, please attach any log files, and the glossary.zip

Whiteboard: target=beta-9
(Reporter)

Comment 4

16 years ago
Created attachment 90330 [details]
MT5beta8b log file

i'm using Win98SE with JRE1.4. 
what exactly do you mean by "setup"? 

i didn't keep a copy of the corrupt glossary file. it is something around 40kB
in size. i'm not sure this log will help you, i may have deleted the log that
was created when the bug occurd. i don't remeber.
(Assignee)

Comment 5

15 years ago
could someone please try and retest this with 5.00 final, I can't seem to
reproduce this.

can it be closed ?
Status: NEW → ASSIGNED

Comment 6

15 years ago
Marking as fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
The MozillaTranslator component is moving to the Mozilla Localisations product.
Product: Browser → Mozilla Localizations
Version: other → unspecified
(Reporter)

Comment 8

15 years ago
for the record: i still get this with WinXPpro, JRE1.4.0_01, MT5.02.
(Reporter)

Comment 9

15 years ago
it is possible that i had this problem due to an incorrect upgrade from one of
the MT5 beta versions. now i deleted everything, extracted the zip again with
the dummyfile, and it appears to save the strings correctly. if i have any other
problem in this subject, i'll post.
Product: Mozilla Localizations → Mozilla Localizations Graveyard
You need to log in before you can comment on or make changes to this bug.