Closed Bug 15025 Opened 20 years ago Closed 20 years ago

Crash after creating new profile

Categories

(Core Graveyard :: Profile: BackEnd, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 13780

People

(Reporter: tague, Assigned: selmer)

Details

I'm still seeing a crash after creating a new profile.  The crash occurs after
the profile is created but before the browser is launched with the new profile.
This is with a clean debug build from 9/27/99 - removed both mozregistry.dat and
any preexisting profiles.  stack trace below :

nsPresContext::PreferenceChanged(const char * 0x027195d0) line 252 + 19 bytes
PrefChangedCallback(const char * 0x027195d0, void * 0x01a67890) line 55
pref_DoCallback(const char * 0x027195d0) line 2294 + 17 bytes
pref_HashPref(const char * 0x027195d0, PrefValue {...}, int 32, int 0) line 1865
+ 9 bytes
PREF_SetDefaultCharPref(const char * 0x027195d0, const char * 0x02719550) line
799 + 17 bytes
nsPref::SetDefaultCharPref(nsPref * const 0x00d0d350, const char * 0x027195d0,
const char * 0x02719550) line 691 + 13 bytes
XPTC_InvokeByIndex(nsISupports * 0x00d0d350, unsigned int 38, unsigned int 2,
nsXPTCVariant * 0x0012e52c) line 135
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x021ba1f0,
nsXPCWrappedNative * 0x02719900, const XPCNativeMemberDescriptor * 0x01eb0748,
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 2, long *
0x00de6d80, long * 0x0012e6cc) line 751 + 44 bytes
WrappedNative_CallMethod(JSContext * 0x021ba1f0, JSObject * 0x01e347f8, unsigned
int 2, long * 0x00de6d80, long * 0x0012e6cc) line 170 + 34 bytes
js_Invoke(JSContext * 0x021ba1f0, unsigned int 2, unsigned int 0) line 655 + 26
bytes
js_Interpret(JSContext * 0x021ba1f0, long * 0x0012ef44) line 2233 + 15 bytes
js_Invoke(JSContext * 0x021ba1f0, unsigned int 0, unsigned int 0) line 671 + 13
bytes
js_Interpret(JSContext * 0x021ba1f0, long * 0x0012f778) line 2233 + 15 bytes
js_Invoke(JSContext * 0x021ba1f0, unsigned int 1, unsigned int 2) line 671 + 13
bytes
js_InternalCall(JSContext * 0x021ba1f0, JSObject * 0x00dd4418, long 14693992,
unsigned int 1, long * 0x0012f8f8, long * 0x0012f8b0) line 748 + 15 bytes
JS_CallFunction(JSContext * 0x021ba1f0, JSObject * 0x00dd4418, JSFunction *
0x0250cce0, unsigned int 1, long * 0x0012f8f8, long * 0x0012f8b0) line 2634 + 32
bytes
nsJSContext::CallFunction(nsJSContext * const 0x021ba360, void * 0x00dd4418,
void * 0x0250cce0, unsigned int 1, void * 0x0012f8f8, int * 0x0012f8f4) line 231
+ 39 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x027157a0) line 103 + 48 bytes
nsEventListenerManager::HandleEvent(nsIPresContext & {...}, nsEvent *
0x0012fc60, nsIDOMEvent * * 0x0012fafc, unsigned int 7, nsEventStatus &
nsEventStatus_eIgnore) line 1025 + 21 bytes
GlobalWindowImpl::HandleDOMEvent(GlobalWindowImpl * const 0x021ba3b4,
nsIPresContext & {...}, nsEvent * 0x0012fc60, nsIDOMEvent * * 0x0012fafc,
unsigned int 1, nsEventStatus & nsEventStatus_eIgnore) line 2791
nsWebShell::OnEndDocumentLoad(nsWebShell * const 0x0221c9e4, nsIDocumentLoader *
0x0221c960, nsIChannel * 0x01d8f3c0, unsigned int 0, nsIDocumentLoaderObserver *
0x0221c9e4) line 3387 + 34 bytes
nsDocLoaderImpl::FireOnEndDocumentLoad(nsDocLoaderImpl * 0x0221c960, nsIChannel
* 0x01d8f3c0, unsigned int 0) line 885
nsDocLoaderImpl::OnStopRequest(nsDocLoaderImpl * const 0x0221c964, nsIChannel *
0x026c8540, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 768
nsLoadGroup::RemoveChannel(nsLoadGroup * const 0x0221c8f0, nsIChannel *
0x026c8540, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 597 + 39 bytes
nsFileChannel::OnStopRequest(nsFileChannel * const 0x026c8544, nsIChannel *
0x026c8430, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 475
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x026cace0) line
283
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x026caa90) line 152 + 12 bytes
PL_HandleEvent(PLEvent * 0x026caa90) line 541 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00d0dab0) line 500 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x02d90094, unsigned int 49339, unsigned int 0,
long 13687472) line 970 + 9 bytes
USER32! 77e71250()
00d0dab0()
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 13780 ***
Status: RESOLVED → VERIFIED
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.