Closed Bug 1502576 Opened Last year Closed 11 months ago

Search suggestion panel disturbs context menu when choose the context menuitem with mouse. And fails the context menu command

Categories

(Firefox :: Search, defect, P1)

57 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- wontfix
firefox63 --- wontfix
firefox64 --- verified
firefox65 --- verified

People

(Reporter: alice0775, Assigned: adw)

References

(Blocks 1 open bug)

Details

(Keywords: regression, ux-error-prevention)

Attachments

(3 files)

This is a regression since Firefox57 Windows10.

I think, search suggestion panel should be triggered by mouseup instead of mousedown.
or mousedown event on the contextmenu should not propagation to toolbar item.

Reproducible: 100%

Steps to reproduce:
1. type something in Search bar.
2. Right click on the Search bar
3. Slowly click on the searchbar contextmenu menuitem
   i.e, mousedown on an menuitem and then mouseup slowly (like it suffered from tenosynovitis)

Actual Results:
Search suggestion panel disturbs context menu.
So, context menu commands occasionally fail.

Expected Results:
Search suggestion panel should not popup while contextmenu displayed


Regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6469a2cb7df662afb23493b5566f99b6802fcb5a&tochange=37b95547f0d27565452136d16b2df2857be840f6


Regressed by:
e4fe078dc013	Zibi Braniecki — Bug 1395871 - Open toolbar menus on mousedown, rather than oncommand.


@Zibi, can you please loo into this?
Flags: needinfo?(gandalf)
Summary: Search suggestion panel disturbs context menu when choose the context menu. And fails the context menu command → Search suggestion panel disturbs context menu when choose the context menuitem with mouse. And fails the context menu command
Attached video screencast
This should be fairly straightforward to fix in that the mousedown listener in the search bar that triggers the popup should be able to detect the mousedown came from the context menu.
Priority: -- → P1
Drew, can you help find an owner for this issue? I notice Mike has marked it as P1, though it is not a recent regression.
Flags: needinfo?(adw)
I did P1 because it was a regression. If that's not correct. adw can change.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Flags: needinfo?(adw)
OS: Windows 10 → All
Hardware: x86_64 → All
Flags: needinfo?(gandalf)
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eaa26fe663cb
The search bar's popup should not open when clicking menu items in its context menu. r=mkaply
https://hg.mozilla.org/mozilla-central/rev/eaa26fe663cb
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Flags: qe-verify+
Flags: in-testsuite-
Attached patch Beta/64 patchSplinter Review
[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1395871

User impact if declined: This bug only affects users who have enabled the search bar.  When they open the context menu in the search bar and click a menu item, the search bar popup will open in front of the context menu and obscure it. As noted in comment 0, this bug has been present since Firefox 57.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Please see comment 0

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It's a three-line patch that simply stops opening the search bar popup when the user clicks a context menu item.  I've tested the patch manually on beta.

String changes made/needed: None
Attachment #9028004 - Flags: approval-mozilla-beta?
Hi, I managed to reproduce this issue in older versions of Firefox Nightly but it no longer occurs in Firefox 65.0a1 (2018-11-27).
I will mark it accordingly.
Comment on attachment 9028004 [details] [diff] [review]
Beta/64 patch

I'm on the fence here as the bug's been around a long time, but fix looks safe enough.  Approved for 64.0b14.
Attachment #9028004 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Hi, I tested this issue on Windows 10 Beta 64.0b13 and I was able to reproduce it there without issues but I can no longer reproduce the issue in the latest Beta 64.0b14, I will mark this issue accordingly.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.