Closed Bug 1502670 Opened Last year Closed Last year

menu button shows with double outlines

Categories

(Thunderbird :: Mail Window Front End, defect)

All
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 65.0

People

(Reporter: aceman, Assigned: Paenglab)

Details

(Keywords: regression)

Attachments

(1 file)

In Tools->Filters (the filter list dialog) the "New..." button seems to have changed the rendering recently. It now has an outline around the main "New..." part (which also doesn't align with the buttons below), and another larger outline (border) when hovering over the 'v' arrow that would open its submenu.

Probably m-c has changed/dropped the styling.
Looks OK on Windows.
Linux looks a bit strange with the double border and Mac has no dropmarker. And yes, Windows look like before the removal of the button[type="menu-button"] binding removal in bug 1457218.

Aceman, can it be that this is since 8 weeks like this?
It is possible, I haven't visited filters list for some time.
This fixes it for me on Linux and Mac.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9020562 - Flags: review?(acelists)
Comment on attachment 9020562 [details] [diff] [review]
1502670-menubutton.patch

Review of attachment 9020562 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, works for me and restores the display as it was before.
Attachment #9020562 - Flags: review?(acelists) → review+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/50bc86d0ddd6
Fix some menubutton glitches on Mac and Linux. r=aceman
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 65.0
You need to log in before you can comment on or make changes to this bug.