Error in processing external entity reference (XHTML DTD)

VERIFIED DUPLICATE of bug 10456

Status

()

defect
P3
blocker
VERIFIED DUPLICATE of bug 10456
20 years ago
20 years ago

People

(Reporter: ian, Assigned: nisheeth_mozilla)

Tracking

Trunk
x86
Windows 98
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 10/14: Requesting clarification before verification as dup, )

Reporter

Description

20 years ago
When I view
   http://www.bath.ac.uk/%7Epy8ieh/internet/projects/mozilla/xml-doctype.xml
...I get the following message from the XML parser:

   XML Parsing Error: Error in processing external entity reference
   Line Number 1, Column 101:
   <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 \
Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/strict.dtd">

The DOCTYPE declaration comes straight from the XHTML spec. I assume it is
correct, but it may not be -- I know very little about XML so far... :-(
I think this is a dup of bug 11948, which was resolved as a dup of a Necko bug,
but I think should have been made a dependency instead.

The behavior has been changing over time (it used to crash rather than give the
error message).
Reporter

Updated

20 years ago
Depends on: 10456
Reporter

Comment 2

20 years ago
Ok; marking as dependency to necko bug 10456.
Reporter

Updated

20 years ago
No longer depends on: 10456
Reporter

Updated

20 years ago
Depends on: 10456
Severity: normal → blocker
The following was written on bug 10456 (where nisheeth was not on the cc: list):

|------- Additional Comments From rpotts@netscape.com  09/29/99 12:53 -------
|Why is the XML handling of DTD files any different than that of HTML for linked
|scripts and style sheets?
|
|In HTML, these linked files are downloaded asynchronously (but with the parser
|blocked) to allow UI feedback.  If the XML parser did a blocking read on the UI
|thread *all user feedback would stop*.
|
|Nisheeth, can XML handle its DTD files the same way that <SCRIPT SRC=foo.js> is
|done by HTML?  I think that this is the right solution...

This makes me think this is not really dependant on that bug.  Raising priority
to blocker since bug 10456 was raised to blocker because of this bug.
Assignee

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
Assignee

Comment 4

20 years ago
This bug should get fixed when I fix bug 10456 (see my latest comment on 10456).
Marking this as a dup...

*** This bug has been marked as a duplicate of 10456 ***

Comment 5

20 years ago
Is this a dup of #10456 or is it dependent on #10456?

Updated

20 years ago
Whiteboard: 10/14: Requesting clarification before verification as dup
Just like bug 11948, eh?  I'd prefer to see one of these left open, but maybe
bug 10456 should just be retitled.
Assignee

Comment 7

20 years ago
I've retitled bug 10456.  I think we can go ahead and verify this bug.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 8

20 years ago
Ok, verifying bug dup of #10456
You need to log in before you can comment on or make changes to this bug.