Closed Bug 1502756 Opened 1 year ago Closed 1 year ago

Consider adding JSDoc documentation for JavaScript files

Categories

(Firefox :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1389341

People

(Reporter: arika.arnzen, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36

Steps to reproduce:

JSDoc provides a documentation generator, creating documentation from a particular format of comments. More about JSDoc can be found here: http://usejsdoc.org/about-getting-started.html.

I think it would be helpful if this kind of automated documentation can be included in Mozilla to help the onboarding process of understanding the large code base. I included an example file of the simplicity of using JSDoc formatting. Commenting is a simple way to ensure that anyone reading code knows exactly what is expected from functions.
Enhancement 
Placing this ticket under Core:DOM , please feel free to change if it's not in right place. 
Thank you
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM
Ever confirmed: true
Product: Firefox → Core
Component: DOM → General
Product: Core → Firefox

There is the Sphinx-JS project to try to do this very thing.

Hey erikrose, is there a tracking bug for Sphinx-JS documentation efforts that I can dupe this off to?

Flags: needinfo?(erik)

Happily, we now support JSDoc-style comments! They just haven't spread through the whole codebase yet. Please refer to bug 1389341 for the registries to twiddle if you want to polish the documentation syntax on more files. Cheers!

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(erik)
Resolution: --- → DUPLICATE
Duplicate of bug: 1389341
You need to log in before you can comment on or make changes to this bug.