tabbed browser should support multiple home pages

VERIFIED DUPLICATE of bug 118835

Status

--
enhancement
VERIFIED DUPLICATE of bug 118835
17 years ago
11 years ago

People

(Reporter: mps, Assigned: jag+mozilla)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

It would be awesome and useful to be able to specify multiple home pages, so
that Mozilla opens with several predefined tabs. This way, I could have all my
standard pages available whenever I start. As an analogy, imagine how awful it
would be if gnome only allowed one application to be opened on the desktop at
startup. Mine comes up with a browser, a command prompt, and a perfmon. For many
computer users, however, the browser is their desktop, and it would be nice to
let them configure a startup set of tabs. This is really a natural concept once
you are in the mindset of a tabbed browser.

Reproducible: Always
Steps to Reproduce:
1.Wish you could have a set of home pages that automatically open in multiple tabs
2.Hit the Home Button
3.

Actual Results:  The home page opens

Expected Results:  All the home pages should open

A reasonable way to do this would be to add a new button labeled "Use Current
Tabs" to Edit/Preferences/Navigator/Home Page. This would set the home pages to
the current tabs, with the currently active tab as the initially active home
tab. Of course, if a URL is entered explicitly, you should have the choice of
making it the home page or adding it to the list of home pages.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 118835 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.