can't run two instances of mozilla with the same profile

VERIFIED DUPLICATE of bug 148839

Status

Core Graveyard
Profile: BackEnd
VERIFIED DUPLICATE of bug 148839
16 years ago
2 years ago

People

(Reporter: Joel Aufrecht, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

16 years ago
Steps to reproduce:
1) Start with RedHat 7.2 and a bunch of old versions of Mozilla 0.9.x and
.mozilla folders
2) remove everything in /usr with the word mozilla in the name
3) rename /root/.mozilla to /root/.mozilla.orig
4) install mozilla 1.0 from mozilla-i686-pc-linux-gnu-1.0-sea.tar.gz
Mozilla starts up with dialogs about profiles.  proceed through all that.
5) run /usr/local/mozilla/mozilla

Expected Result
A second instance of mozilla starts

Actual Result
1) The Select User Profile dialog pops up.  "Default" is selected, so hit Start
Mozilla
2) An error message appears: 
  Mozilla cannot use the profile "default" because it is in use.
  Please choose another profile or create a new one.

This did not occur in mozilla 0.9.x.

Comment 1

16 years ago
This means that you can't run mail and the browser at the same time in separate
sessions. Running them as one session creates other problems

Comment 2

16 years ago
This means that you can't run mail and the browser at the same time in separate
sessions. Running them as one session creates other problems.

This began for me in Lycoris build 44 (amethyst) with the release of 1.0 RC3,
and continues with 1.0 .  The problem does not recur if I re-install versions
earlier than RC3. I suspect this is a side-effect of another bug "fix" that
tries to keep multiple sessions from updating the same profile.

That's exactly what it's a side effect of -- a fix that locks the profile just
like NS4 does so that you do not get profile corruption when both sessions try
to write to it at once.  Are you saying you'd rather have your profile get
completely messed up every so often?

To profile manager, and this is a duplicate...
Assignee: Matti → ccarlen
Component: Browser-General → Profile Manager BackEnd
QA Contact: imajes-qa → ktrina
Whiteboard: DUPEME

Comment 4

16 years ago
marking dupe

*** This bug has been marked as a duplicate of 148839 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
running 2 session with the same profile is invalid.

It's a dupe if you want only a second window.
v
Status: RESOLVED → VERIFIED
(Assignee)

Comment 6

16 years ago
> Running them as one session creates other problems

What sort of problems? Running them as one session is certainly what mozilla was
designed to do and how nearly everybody uses it. It sounds like you were
encountering other problems and using 2 instances sharing a profile as a
workaround. This is an unusual work pattern and not one that was considered when
coming up with the locking approach.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.