Closed Bug 1503187 Opened 3 years ago Closed 3 years ago

Firefox reproducibly leads to graphics hardware crash when viewing specific URL

Categories

(Core :: Graphics, defect)

63 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1479795
Tracking Status
firefox63 --- affected
firefox64 --- affected
firefox65 --- affected

People

(Reporter: mail, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

Hardware: Lenovo ThinkPad T470p with Intel HD Graphics 630, NVIDIA GeForce 940MX, 2560x1440 HiDPI Display
Software: Windows 10 x64 Version 1803, Intel Graphics Driver 23.20.16.4973, NVIDIA Graphics Driver 23.21.13.9125 (both according to Device Manager)

1. Close all open Firefox windows and launch a new Firefox instance.
2. Browse to https://www.hetzner.de/cloud

(Someone better mirror this URL exactly before they change it, a simple File -> Save Page As isn't sufficient to reproduce this bug)


Actual results:

Either "This tab has crashed", "Application has been blocked from accessing graphics hardware" (firefox.exe) or even a PAGE_FAULT_IN_NONPAGED_AREA bluescreen.


Expected results:

No crash at all
Hello Colin - If you have a crash report listed in about:crashes (type that in the URL bar), can you kindly paste it here?
Flags: needinfo?(mail)
I have submitted the related crash report "bp-e5528e74-1f02-45c4-aeb4-0396d0181030" to Mozilla yesterday.

Is the report ID sufficient or do you need the report as a self-contained file attached to this bug report?
In that case, please let me know how to export it into a file.
Flags: needinfo?(mail)
Thanks Colin - I added the crash signature to this bug. I see some other Win 10 crashes in crash-stats - https://bit.ly/2ETSPqU. It appears on 63 release we have about 30 crashes so far, all Win 10.
Status: UNCONFIRMED → NEW
Crash Signature: [@ igd10iumd64.dll | CDeviceChild<T>::~CDeviceChild<T>]
Component: Untriaged → Graphics
Ever confirmed: true
Keywords: crash
Product: Firefox → Core
Looks like this crash is becoming more common, although it is because the faulty driver is becoming more popular. I need to check on whether or not a new driver has been published since we last checked.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1479795
You need to log in before you can comment on or make changes to this bug.