download manager appends .exe to non .exe

VERIFIED DUPLICATE of bug 120327

Status

VERIFIED DUPLICATE of bug 120327
17 years ago
14 years ago

People

(Reporter: cmdryoda, Assigned: bugzilla)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

When downloading a file which doesn't have a .exe extension, the .exe extension
is applied. For example with a .zip file when downloading, mozilla will add .exe
to the .zip(i.e filename.zip.exe). 

Reproducible: Always
Steps to Reproduce:
1.Download a .zip file, also it happens with any file that doesn't end with .exe
2.
3.

Actual Results:  added .exe to the end of the file, so it looked like
filename.zip.exe

Expected Results:  left off the .exe

I tried downloading .zip files from other sites, and the .exe isn't added to the
end.http://www.btinternet.com/~martin.webb/download/zip.htm.
I think the problem might be the way the file is being called. From the   sun
site the file is being called from a perl script. From the above site I would
just click on the link. Also from the sun site I don't get the dialog box which
ask me if I would like to open the file with winzip.
(Reporter)

Comment 1

17 years ago
Created attachment 86983 [details]
Screenshot of Mozilla 1.0 downloading .zip file

This is from the sun site with Mozilla 1.0
(Reporter)

Comment 2

17 years ago
Created attachment 86984 [details]
Screenshot of IE 6 downloading .zip file

This is from the sun site downloading the same file, but ie doesn't append the
.exe to the end
Dup of the extension-appending being too zealous bug.

*** This bug has been marked as a duplicate of 120327 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.