Closed Bug 1503498 Opened Last year Closed Last year

Simplify ForwardingExternalImage handling in AsyncImagePipelineManager

Categories

(Core :: Graphics: WebRender, enhancement, P4)

enhancement

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

Attachments

(1 file, 2 obsolete files)

For ForwardingExternalImage, SharedSurfacesParent::Release() is manually called in some places. It seems better that if SharedSurfacesParent::Release() is automatically called during ForwardingExternalImage's destruction.
Assignee: nobody → sotaro.ikeda.g
Attachment #9021439 - Flags: review?(aosmond)
Comment on attachment 9021439 [details] [diff] [review]
patch - Simplify ForwardingExternalImage handling in AsyncImagePipelineManager

Review of attachment 9021439 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #9021439 - Flags: review?(aosmond) → review+
Duplicate of this bug: 1501925
Priority: -- → P4
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5dd599d4a437
Simplify ForwardingExternalImage handling in AsyncImagePipelineManager r=aosmond
https://hg.mozilla.org/mozilla-central/rev/5dd599d4a437
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.