Closed Bug 1503561 Opened Last year Closed Last year

Intermittent browser/components/urlbar/tests/browser/browser_UrlbarInput_tooltip.js | Test timed out -

Categories

(Firefox :: Address Bar, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1504985
Firefox 65
Tracking Status
firefox65 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: dao)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: csabou [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=208884352&repo=autoland

https://queue.taskcluster.net/v1/task/JzHl03fuQhqXFGc5rKnaaQ/runs/0/artifacts/public/logs/live_backing.log

[task 2018-10-31T12:31:15.365Z] 12:31:15     INFO - TEST-OK | browser/components/payments/test/browser/browser_show_dialog.js | took 5987ms
[task 2018-10-31T12:31:15.401Z] 12:31:15     INFO - checking window state
[task 2018-10-31T12:31:15.418Z] 12:31:15     INFO - TEST-START | browser/components/payments/test/browser/browser_total.js
[task 2018-10-31T12:31:15.481Z] 12:31:15     INFO - TEST-INFO | started process screentopng
[task 2018-10-31T12:31:15.881Z] 12:31:15     INFO - TEST-INFO | screentopng: exit 0
[task 2018-10-31T12:31:15.882Z] 12:31:15     INFO - Buffered messages logged at 12:31:15
[task 2018-10-31T12:31:15.883Z] 12:31:15     INFO - Entering test bound setup_head
[task 2018-10-31T12:31:15.884Z] 12:31:15     INFO - Leaving test bound setup_head
[task 2018-10-31T12:31:15.884Z] 12:31:15     INFO - Entering test bound test_total
[task 2018-10-31T12:31:15.885Z] 12:31:15     INFO - Console message: [JavaScript Error: "TelemetryStopwatch: requesting elapsed time for nonexisting stopwatch. Histogram: "FX_TAB_SWITCH_COMPOSITE_E10S_MS", key: "null"" {file: "resource://gre/modules/TelemetryStopwatch.jsm" line: 388}]
[task 2018-10-31T12:31:15.886Z] 12:31:15     INFO - timeElapsed@resource://gre/modules/TelemetryStopwatch.jsm:388:9
[task 2018-10-31T12:31:15.887Z] 12:31:15     INFO - timeElapsed@resource://gre/modules/TelemetryStopwatch.jsm:208:12
[task 2018-10-31T12:31:15.889Z] 12:31:15     INFO - onPaint@resource:///modules/AsyncTabSwitcher.jsm:744:18
[task 2018-10-31T12:31:15.890Z] 12:31:15     INFO - handleEvent@resource:///modules/AsyncTabSwitcher.jsm:1046:9
[task 2018-10-31T12:31:15.891Z] 12:31:15     INFO - EventListener.handleEvent*AsyncTabSwitcher@resource:///modules/AsyncTabSwitcher.jsm:140:5
[task 2018-10-31T12:31:15.893Z] 12:31:15     INFO - _getSwitcher@chrome://browser/content/tabbrowser.js:4132:24
[task 2018-10-31T12:31:15.893Z] 12:31:15     INFO - updateCurrentBrowser@chrome://browser/content/tabbrowser.js:851:9
[task 2018-10-31T12:31:15.894Z] 12:31:15     INFO - _setupEventListeners/<@chrome://browser/content/tabbrowser.js:4500:9
[task 2018-10-31T12:31:15.895Z] 12:31:15     INFO - set selectedIndex@chrome://global/content/elements/tabbox.js:201:7
[task 2018-10-31T12:31:15.896Z] 12:31:15     INFO - set selectedPanel@chrome://global/content/elements/tabbox.js:215:5
[task 2018-10-31T12:31:15.897Z] 12:31:15     INFO - set_selectedIndex@chrome://global/content/bindings/tabbox.xml:172:15
[task 2018-10-31T12:31:15.897Z] 12:31:15     INFO - set_selectedItem@chrome://global/content/bindings/tabbox.xml:197:34
[task 2018-10-31T12:31:15.898Z] 12:31:15     INFO - set selectedTab@chrome://global/content/elements/tabbox.js:80:9
[task 2018-10-31T12:31:15.899Z] 12:31:15     INFO - set selectedTab@chrome://browser/content/tabbrowser.js:274:5
[task 2018-10-31T12:31:15.900Z] 12:31:15     INFO - _blurTab@chrome://browser/content/tabbrowser.js:3181:24
[task 2018-10-31T12:31:15.901Z] 12:31:15     INFO - _beginRemoveTab@chrome://browser/content/tabbrowser.js:2881:5
[task 2018-10-31T12:31:15.902Z] 12:31:15     INFO - removeTab@chrome://browser/content/tabbrowser.js:2789:10
[task 2018-10-31T12:31:15.903Z] 12:31:15     INFO - removeTab@resource://testing-common/BrowserTestUtils.jsm:1216:5
[task 2018-10-31T12:31:15.904Z] 12:31:15     INFO - withNewTab@resource://testing-common/BrowserTestUtils.jsm:118:7
[task 2018-10-31T12:31:15.904Z] 12:31:15     INFO - async*test_tab_modal/<@chrome://mochitests/content/browser/browser/components/payments/test/browser/browser_show_dialog.js:294:11
[task 2018-10-31T12:31:15.905Z] 12:31:15     INFO - async*withNewTab@resource://testing-common/BrowserTestUtils.jsm:111:24
[task 2018-10-31T12:31:15.906Z] 12:31:15     INFO - async*test_tab_modal@chrome://mochitests/content/browser/browser/components/payments/test/browser/browser_show_dialog.js:256:9
[task 2018-10-31T12:31:15.907Z] 12:31:15     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1097:34
[task 2018-10-31T12:31:15.907Z] 12:31:15     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1088:16
[task 2018-10-31T12:31:15.908Z] 12:31:15     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-31T12:31:15.909Z] 12:31:15     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-31T12:31:15.910Z] 12:31:15     INFO - 
[task 2018-10-31T12:31:15.911Z] 12:31:15     INFO - Buffered messages finished
[task 2018-10-31T12:31:15.912Z] 12:31:15     INFO - TEST-UNEXPECTED-FAIL | browser/components/payments/test/browser/browser_total.js | [JavaScript Error: "TelemetryStopwatch: requesting elapsed time for nonexisting stopwatch. Histogram: "FX_TAB_SWITCH_COMPOSITE_E10S_MS", key: "null"" {file: "resource://gre/modules/TelemetryStopwatch.jsm" line: 388}]
[task 2018-10-31T12:31:15.913Z] 12:31:15     INFO - timeElapsed@resource://gre/modules/TelemetryStopwatch.jsm:388:9
[task 2018-10-31T12:31:15.913Z] 12:31:15     INFO - timeElapsed@resource://gre/modules/TelemetryStopwatch.jsm:208:12
[task 2018-10-31T12:31:15.914Z] 12:31:15     INFO - onPaint@resource:///modules/AsyncTabSwitcher.jsm:744:18
[task 2018-10-31T12:31:15.915Z] 12:31:15     INFO - handleEvent@resource:///modules/AsyncTabSwitcher.jsm:1046:9
[task 2018-10-31T12:31:15.916Z] 12:31:15     INFO - EventListener.handleEvent*AsyncTabSwitcher@resource:///modules/AsyncTabSwitcher.jsm:140:5
[task 2018-10-31T12:31:15.917Z] 12:31:15     INFO - _getSwitcher@chrome://browser/content/tabbrowser.js:4132:24
[task 2018-10-31T12:31:15.918Z] 12:31:15     INFO - updateCurrentBrowser@chrome://browser/content/tabbrowser.js:851:9
[task 2018-10-31T12:31:15.918Z] 12:31:15     INFO - _setupEventListeners/<@chrome://browser/content/tabbrowser.js:4500:9
[task 2018-10-31T12:31:15.919Z] 12:31:15     INFO - set selectedIndex@chrome://global/content/elements/tabbox.js:201:7
[task 2018-10-31T12:31:15.920Z] 12:31:15     INFO - set selectedPanel@chrome://global/content/elements/tabbox.js:215:5
[task 2018-10-31T12:31:15.921Z] 12:31:15     INFO - set_selectedIndex@chrome://global/content/bindings/tabbox.xml:172:15
[task 2018-10-31T12:31:15.922Z] 12:31:15     INFO - set_selectedItem@chrome://global/content/bindings/tabbox.xml:197:34
[task 2018-10-31T12:31:15.923Z] 12:31:15     INFO - set selectedTab@chrome://global/content/elements/tabbox.js:80:9
[task 2018-10-31T12:31:15.925Z] 12:31:15     INFO - set selectedTab@chrome://browser/content/tabbrowser.js:274:5
[task 2018-10-31T12:31:15.926Z] 12:31:15     INFO - _blurTab@chrome://browser/content/tabbrowser.js:3181:24
[task 2018-10-31T12:31:15.927Z] 12:31:15     INFO - _beginRemoveTab@chrome://browser/content/tabbrowser.js:2881:5
[task 2018-10-31T12:31:15.928Z] 12:31:15     INFO - removeTab@chrome://browser/content/tabbrowser.js:2789:10
[task 2018-10-31T12:31:15.929Z] 12:31:15     INFO - removeTab@resource://testing-common/BrowserTestUtils.jsm:1216:5
[task 2018-10-31T12:31:15.931Z] 12:31:15     INFO - withNewTab@resource://testing-common/BrowserTestUtils.jsm:118:7
[task 2018-10-31T12:31:15.932Z] 12:31:15     INFO - async*test_tab_modal/<@chrome://mochitests/content/browser/browser/components/payments/test/browser/browser_show_dialog.js:294:11
[task 2018-10-31T12:31:15.933Z] 12:31:15     INFO - async*withNewTab@resource://testing-common/BrowserTestUtils.jsm:111:24
[task 2018-10-31T12:31:15.934Z] 12:31:15     INFO - async*test_tab_modal@chrome://mochitests/content/browser/browser/components/payments/test/browser/browser_show_dialog.js:256:9
[task 2018-10-31T12:31:15.935Z] 12:31:15     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1097:34
[task 2018-10-31T12:31:15.936Z] 12:31:15     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1088:16
[task 2018-10-31T12:31:15.938Z] 12:31:15     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-31T12:31:15.939Z] 12:31:15     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-31T12:31:15.940Z] 12:31:15     INFO -  - 
[task 2018-10-31T12:31:15.941Z] 12:31:15     INFO - Stack trace:
[task 2018-10-31T12:31:15.942Z] 12:31:15     INFO - chrome://mochitests/content/browser/browser/components/payments/test/browser/head.js:onConsoleMessage:365
[task 2018-10-31T12:31:15.944Z] 12:31:15     INFO - chrome://mochikit/content/tests/SimpleTest/specialpowersAPI.js:observe/<:388
[task 2018-10-31T12:31:15.945Z] 12:31:15     INFO - waitForMessageFromWidget: paymentDialogReady

The failing test was introduced with this push: https://hg.mozilla.org/integration/autoland/rev/44f565c70e49de7ae1ed535b81cad31b89274d32
Also occurs on tier 1, intermittently: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=77b6b02860b6ac75dac672e6945c136f186907ae&group_state=expanded&selectedJob=209182766
Summary: Intermittent [TV] browser/components/urlbar/tests/browser/browser_UrlbarInput_tooltip.js | Test timed out - → Intermittent browser/components/urlbar/tests/browser/browser_UrlbarInput_tooltip.js | Test timed out -
Test got added in bug 1496443.
Blocks: 1496443
Flags: needinfo?(dao+bmo)
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)
See Also: → 1504191
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/16689402ad95
Make browser_UrlbarInput_tooltip.js more robust. r=Standard8
https://hg.mozilla.org/mozilla-central/rev/16689402ad95
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Duplicate of this bug: 1504985
See Also: 1504191
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1504985
You need to log in before you can comment on or make changes to this bug.