Merge TabTarget with WorkerTarget and rename it to Target

RESOLVED FIXED in Firefox 65

Status

P2
enhancement
RESOLVED FIXED
5 months ago
2 months ago

People

(Reporter: ochameau, Assigned: ochameau)

Tracking

(Blocks: 3 bugs)

unspecified
Firefox 65
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

(Whiteboard: dt-fission)

Attachments

(8 attachments)

(Assignee)

Description

5 months ago
A preliminary step before merging fronts with TabTarget would be to first merge TabTarget and WorkerTarget in order to have only one class.

It also introduces another preliminary step into TabTarget refactoring. WorkerTarget is instantiated directly with a front as contructor argument, where TabTarget is still instantiating all its fronts within TabTarget.attach.

As we merge TabTarget/WorkerTarget with their related fronts, we will no longer instantiate the front from within one of its sub method (here TabTarget.attach).
So passing the front as an argument should help us later merge these classes altogether.
(Assignee)

Updated

5 months ago
Assignee: nobody → poirot.alex
Severity: normal → enhancement
Priority: -- → P2
(Assignee)

Comment 2

5 months ago
Now all targets are considered as remote, so isRemote attribute is misleading.
Remote means that we are going through the RDP protocol to debug the target
and we now always do. If some callsite wants to do something special for local tabs
it is better to read target.isLocalTab attribute.

MozReview-Commit-ID: IYlj0wO02PO
(Assignee)

Comment 3

5 months ago
MozReview-Commit-ID: 28A1mNQG9P2

Depends on D11009
(Assignee)

Comment 4

5 months ago
MozReview-Commit-ID: DxTqoIbVle6

Depends on D11010
(Assignee)

Comment 5

5 months ago
MozReview-Commit-ID: 5v9HaEUE9E6

Depends on D11011
(Assignee)

Comment 6

5 months ago
MozReview-Commit-ID: 3tPRSL8OHFY

Depends on D11012
(Assignee)

Comment 7

5 months ago
MozReview-Commit-ID: 58iL6HyXjM4

Depends on D11013
(Assignee)

Comment 8

5 months ago
MozReview-Commit-ID: 8oapi6dtQdf

Depends on D11014
(Assignee)

Comment 9

5 months ago
MozReview-Commit-ID: BpmiEm05QIF

Depends on D11015
(Assignee)

Comment 10

5 months ago
I added many preliminary cleanups patches in this queue, only the 4 last patches are really about this merge.
(Assignee)

Updated

4 months ago
Whiteboard: dt-fission
(Assignee)

Updated

4 months ago
Duplicate of this bug: 1503184

Comment 12

4 months ago
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cdf27890e172
Remove Target.isRemote. r=yulia
https://hg.mozilla.org/integration/autoland/rev/6bc9f5036d6b
Stop storing threadActor on TabTarget. r=yulia
https://hg.mozilla.org/integration/autoland/rev/3bf0588acd48
Remove TabTarget checks against non-remote targets. r=yulia
https://hg.mozilla.org/integration/autoland/rev/f684c3a76f74
Remove checks against non-remote targets. r=yulia
https://hg.mozilla.org/integration/autoland/rev/f76462395751
Fix the typing of newSource event on the worker target actor. r=yulia
https://hg.mozilla.org/integration/autoland/rev/5cdcb5f251db
Merge TabTarget and WorkerTarget. r=yulia
https://hg.mozilla.org/integration/autoland/rev/7d063b78f631
Remove WorkerTarget. r=yulia
https://hg.mozilla.org/integration/autoland/rev/56f178d7badd
Rename TabTarget to Target. r=yulia
(Assignee)

Updated

3 months ago
Depends on: 1513565
(Assignee)

Updated

2 months ago
Blocks: 1522571
(Assignee)

Updated

2 months ago
Blocks: 1522572
(Assignee)

Updated

2 months ago
Blocks: 1522573
You need to log in before you can comment on or make changes to this bug.