Closed Bug 1503644 Opened Last year Closed Last year

Start submitting Beta Language packs to AMO in `listed` state

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(firefox-esr60 fixed, firefox64 fixed, firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- fixed
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: Callek, Assigned: Callek)

Details

Attachments

(1 file)

So, with the completion of AMO PR https://github.com/mozilla/addons-server/issues/8180 the restriction that made it so I couldn't `list` beta language packs is now gone.

It also helps QE and Relman be comfortable with the plans in phase 1 of multi-lingual-desktop that mstriemer is working on if we can list these.

I've tested this now and there would be no impact to users if we start listing these for beta, (there are additional complications with deved right now that makes it so that we cannot list those in particular)

We could in theory also start listing 'esr' as well, but thats not a road we need to cross today.
Comment on attachment 9021593 [details]
Bug 1503644 - Start submitting Beta Language packs to AMO in 'listed' state. r=aki

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: Beta language packs not listed on AMO

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Mstriemer needs this for better QE ability of a feature riding with 65 (and preffed in 64). So that we can test on beta the same codepath that will be used on release.

It enables language packs to be listed for user download from AMO directly for beta, and a recent change to AMO means this won't impact release channel users looking for language packs on AMO.

Requesting the approval+ before the review+ since the hope is to have this uplifted in time for tomorrows beta's

String changes made/needed: None
Attachment #9021593 - Flags: approval-mozilla-beta?
Pushed by jwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fd5e587c92bf
Start submitting Beta Language packs to AMO in 'listed' state. r=aki
https://hg.mozilla.org/mozilla-central/rev/fd5e587c92bf
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Comment on attachment 9021593 [details]
Bug 1503644 - Start submitting Beta Language packs to AMO in 'listed' state. r=aki

[Triage Comment]
Allows Beta langpacks to be listed on AMO, which is needed for other work underway. Approved for 64.0b6.
Attachment #9021593 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.